Finale SmartMusic
  Home | Log In | Register | Search | Help
   
MakeMusic Forum > Public Forums > FinaleScript - FORUM HAS MOVED! > Script help to change manuscript texture  Forum Quick Jump
 
You cannot post new topics in this forum. You cannot reply to topics in this forum. Printable Version
[ << Previous Thread | Next Thread >> | Show Newest Post First ]

gogreen
Registered Member



Click to send gogreen email.Click to visit gogreen's website.Send a Private Message to gogreenAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Dec 1999
Total Posts : 1618
 
   Posted 10/2/2016 6:49 PM (GMT -5)    Quote This PostAlert An Admin About This Post.
I've used a script to change the manuscript texture to white--my preference, but ever since about Finale 2007, Finale doesn't save this preference. The script I've been using in Finale 2014.5 was this:

menu item “Preferences”
highlight “Palettes and Backgrounds”
click “Palettes and Background”
click radio “solid color” near “Manuscript Texture”
button ok

As I recall, Charles Lawrence suggested this syntax last January or so. Unfortunately, this script doesn't work in Finale 25. I've tried creating it anew and adding "press down arrow" in places to get it to work, but it's a no-go for me. The script hangs right after I see the Preferences window. Can anyone suggest a syntax that works in finale 25? Thanks.


Arthur J. Michaels

/www.facebook.com/composerarthurjmichaels

Finale 2000, 2001, 2003, 2005, 2006, 2007, 2011b.r2, 2014d, 2014.5, Finale 25
Core i7 860 @ 2.80 GHz, 8.0 GB RAM, Windows 10 Home x64
Garritan COMB2, GPO4, GPO5, Aria Player 1.872, Audacity 2.1.2
Dell 2408 WFP, 1920x1200
M-Audio Delta Audiophile 2496
Casio WK-3000
M-Audio AV40 monitors
AKG K-240 Studio headphones
Brother MFC-L2740DW printer

Back to Top

Charles Lawrence
Registered Member



Click to send Charles Lawrence email.Personal Homepage Not AvailableSend a Private Message to Charles LawrenceAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Dec 2009
Total Posts : 3638
 
   Posted 10/6/2016 8:28 AM (GMT -5)    Quote This PostAlert An Admin About This Post.
Authur,
 
When a script fails after executing the first line, it is indicative of malformed XML.  Copy/pasting from this forum suffers from this malady.  Simply copy the XML file from F2014.5 to F25 and you should be OK, or reenter the script from scratch in the F25 Finalescript editor window.  Remember the directory for F25 is called "Finale", so place it here, for instance: "C:\Users\<username>\AppData\Roaming\MakeMusic\Finale\Finalescript\Myscripts"
 
Attached is the XML that works in F25.
 


"Anything is possible if you don't know what you are talking about!"

Windows 10 Professional (x64) (build 10586)
 
3.50 gigahertz Intel Core i7-5930K, Multi-core (6 total), Hyper-threaded (12 total)
32638 Megabytes Usable Installed Memory, 17514.37 Gigabytes Usable Hard Drive Capacity
NVIDIA GeForce GTX 980 - 4GB [Display adapter]
ASUS Rampage V Extreme motherboard, Realtek HD Audio

Finale 2014.5.6359
Garritan GPO4.02


Cakewalk SONAR X3 - (X3e build 244) - x64, Sound Forge Audio Studio 10.0, Audacity 2.1.0
Sharpeye 2.68, PhotoScore Ultimate 7.0.2, SmartScore X2 Pro 10.5.8

"There is a world of difference between a person who has a big problem and a person who makes a problem big." – John Maxwell

Post Edited (Charles Lawrence) : 10/6/2016 7:31:17 AM (GMT-5)



File Attachment :
gogreen.xml   0KB (text/xml)
This file has been downloaded 43 time(s).
Back to Top

gogreen
Registered Member



Click to send gogreen email.Click to visit gogreen's website.Send a Private Message to gogreenAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Dec 1999
Total Posts : 1618
 
   Posted 10/6/2016 12:29 PM (GMT -5)    Quote This PostAlert An Admin About This Post.
I copied your .xml file and brought it into Finale 25. Works perfectly now. Thank you, Charles.

For one of my attempts to solve this problem, I reentered a new script from scratch into Finale 25, but it, too, hung. Anyway, your script works.


Arthur J. Michaels

/www.facebook.com/composerarthurjmichaels

Finale 2000, 2001, 2003, 2005, 2006, 2007, 2011b.r2, 2014d, 2014.5, Finale 25
Core i7 860 @ 2.80 GHz, 8.0 GB RAM, Windows 10 Home x64
Garritan COMB2, GPO4, GPO5, Aria Player 1.872, Audacity 2.1.2
Dell 2408 WFP, 1920x1200
M-Audio Delta Audiophile 2496
Casio WK-3000
M-Audio AV40 monitors
AKG K-240 Studio headphones
Brother MFC-L2740DW printer

Back to Top

Charles Lawrence
Registered Member



Click to send Charles Lawrence email.Personal Homepage Not AvailableSend a Private Message to Charles LawrenceAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Dec 2009
Total Posts : 3638
 
   Posted 10/6/2016 3:48 PM (GMT -5)    Quote This PostAlert An Admin About This Post.
gogreen said...
I copied your .xml file and brought it into Finale 25. Works perfectly now. Thank you, Charles.

For one of my attempts to solve this problem, I reentered a new script from scratch into Finale 25, but it, too, hung. Anyway, your script works.

That is odd.  It should have worked.  Oh well.  BTW, the script I posted is the exact same as for F2014.5.


"Anything is possible if you don't know what you are talking about!"

Windows 10 Professional (x64) (build 10586)
 
3.50 gigahertz Intel Core i7-5930K, Multi-core (6 total), Hyper-threaded (12 total)
32638 Megabytes Usable Installed Memory, 17514.37 Gigabytes Usable Hard Drive Capacity
NVIDIA GeForce GTX 980 - 4GB [Display adapter]
ASUS Rampage V Extreme motherboard, Realtek HD Audio

Finale 2014.5.6359
Garritan GPO4.02


Cakewalk SONAR X3 - (X3e build 244) - x64, Sound Forge Audio Studio 10.0, Audacity 2.1.0
Sharpeye 2.68, PhotoScore Ultimate 7.0.2, SmartScore X2 Pro 10.5.8

"There is a world of difference between a person who has a big problem and a person who makes a problem big." – John Maxwell

Back to Top

gogreen
Registered Member



Click to send gogreen email.Click to visit gogreen's website.Send a Private Message to gogreenAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Dec 1999
Total Posts : 1618
 
   Posted 10/9/2016 11:00 PM (GMT -5)    Quote This PostAlert An Admin About This Post.
Yes, it is odd. Anyway, it's working now. Thanks!


Arthur J. Michaels

/www.facebook.com/composerarthurjmichaels

Finale 2000, 2001, 2003, 2005, 2006, 2007, 2011b.r2, 2014d, 2014.5, Finale 25
Core i7 860 @ 2.80 GHz, 8.0 GB RAM, Windows 10 Home x64
Garritan COMB2, GPO4, GPO5, Aria Player 1.872, Audacity 2.1.2
Dell 2408 WFP, 1920x1200
M-Audio Delta Audiophile 2496
Casio WK-3000
M-Audio AV40 monitors
AKG K-240 Studio headphones
Brother MFC-L2740DW printer

Back to Top
You cannot post new topics in this forum. You cannot reply to topics in this forum. Printable Version
   
Forum Information
Currently it is Monday, April 24, 2017 1:15 PM (GMT -5)
There are a total of 437,696 posts in 63,793 threads.
In the last 3 days there were 0 new threads and 0 reply posts. View Active Threads