Finale SmartMusic
  Home | Log In | Register | Search | Help
   
MakeMusic Forum > Public Forums > FinaleScript - FORUM HAS MOVED! > Bug!  Forum Quick Jump
 
You cannot post new topics in this forum. You cannot reply to topics in this forum. Printable Version
[ << Previous Thread | Next Thread >> | Show Oldest Post First ]

Thomas Hansen
Horn Player, Freelancer Engraver.



Email Address Not AvailableClick to visit Thomas Hansen's website.Send a Private Message to Thomas HansenAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Mar 2001
Total Posts : 66
 
   Posted 5/12/2004 8:07 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Hi all (Norman, Robert, Michael),

I can reproduce the problem in the page counter, too. The two vertical bars appear if I click on the page counter field, type the number of the page I want to go and hit <enter>. It will display the <EOL> character (the 2 bars), followed by the number of the page I typed.

I also confirm that the problem is not present in any other software I use. And I also confirm the problem in the Finale´s Description text box.

Hope it helps...

Thomas


----------------------------------------------------------

Helloooooooooooooo... Curse!

Back to Top

Norman
Registered Member

Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to NormanAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Nov 2003
Total Posts : 12
 
   Posted 5/12/2004 10:30 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
Hi Robert,

The Microsoft Word 'Comments' text box under File/Properties is OK on my machine.

The strange end-line behavior only occurs with Finale and I probably only noticed it when
I downloaded the Finalescript update and wanted to try it out.

I recall having seen those two vertical bars in the Page Counter at the bottom of the window.

Norman
Back to Top

Robert P.
Registered Member



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to Robert P.AIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Apr 2004
Total Posts : 1691
 
   Posted 5/11/2004 9:26 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
Norman and Thomas,

Is there any other software where you can see this behavior?
I think that in Microsoft Word, the 'Comments' text box in File/Properties (or Info - I don't quite remember) is like Finale's Description text box.

Did you remember that it DID work at some point (running XP SP1), and then no more? If you do, can't you think of any change brought to your system settings in the mean time?

Thanks
Robert
Back to Top

Michael Johnson
Registered Member



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to Michael JohnsonAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Mar 2004
Total Posts : 1317
 
   Posted 5/10/2004 1:30 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Hi Norman and Thomas--
As we can see from your experiment, the issue is not limited to the Plug-in. Since Finale 2004b as been in the market place for several months and I haven't found reports of other XP users with a similar experience, my conclusion is something unique to your system is causing the behavior. I would guess it could be a non-standard keyboard or the use of an IME to enter foreign characters.
If you have trouble tracking this down, please pop over to the other forum or email winsupport for help.
Cheers,


Michael Johnson
QA Supervisor
MakeMusic!

Back to Top

Norman
Registered Member

Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to NormanAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Nov 2003
Total Posts : 12
 
   Posted 5/8/2004 7:49 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
Michael,

I can confirm that the same behavior occurs in the File menu>>File Info>>Description field.
Every time I hit enter those funny two vertical bars come up !

Thanks,

Norman
Back to Top

Michael Johnson
Registered Member



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to Michael JohnsonAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Mar 2004
Total Posts : 1317
 
   Posted 5/7/2004 10:59 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
Hi Thomas--

We are looking into this. Do you see the same behavior happening in File menu>> File Info >> Description edit field in Finale?

Thanks,


Michael Johnson
QA Supervisor
MakeMusic!

Back to Top

Thomas Hansen
Horn Player, Freelancer Engraver.



Email Address Not AvailableClick to visit Thomas Hansen's website.Send a Private Message to Thomas HansenAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Mar 2001
Total Posts : 66
 
   Posted 5/6/2004 3:44 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Michael,

I´ll try to be more specific about the problem and my system.

I´ve got Finale 2004b installed on Windows XP Version 2002 SP1. The machine is a HP Pentium 4 2.4GHz, 256 Mb DRAM, 40Gb HD SCSI.
Residents programs: Mozilla 1.7b, OpenOffice.org 1.1.1, AVG Antivirus 7.0, Exodus (a Jabber IM client)
Non-resident other programs: CorelDraw! 11.

Finalescript used to work with this configuration. I am not sure if AVG Antivirus was installed before my last sucessfull usage of the plugin, but I tried to remove it from memory and run FS, with the same results.

Now, a better (technical) description of the problem:

Apparently, the procedure (object?) that handles the script editor is misunderstanding the <CR><LF> characters pair. Instead of promoting a line change, it exibits it as a character (see the attachment on my second post). The problem must be in the script editor and not in the script, since if I cut this character and paste to another editor, it will just do a line change. I am able to select the whole script and copy/paste to notepad (Home, Ctrl+Shift+End), and it will be shown perfectly there, but I cannot see the entire script on the script editor - only the first line. There is no scrollbar available, and even though the right arrow works, it won´t make the text roll. If I delete the <cr><lf> character, there appears a horizontal scrollbar, which lets me advance to the next <cr><lf> pair, and so on. If I hit the <enter> key, it shows me the same <cr><lf> character, instead of going to a new line.

I suspect the problem is in the library which handles the script editor, or in the way that this object is invoked (maybe using some default value which differs in some few Windows installations).

Hope it helps!

Thanks,

Thomas


----------------------------------------------------------

Helloooooooooooooo... Curse!

Back to Top

Michael Johnson
Registered Member



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to Michael JohnsonAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Mar 2004
Total Posts : 1317
 
   Posted 5/5/2004 1:32 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Dear Norman and Thomas--
It does sound like it is something on your system since not everyone can reproduce the problem. I believe both of you have gotten it to work at one time, so the big question is what changed since then? Do any of the following apply: New system settings, display settings, other software running in the background? Does copy/paste work the same in other applications and throughout Finale? Does copy/paste work the same in the Command Line plug-in (You can copy paste into there).
Like Robert, I am just trying to narrow the reason for the change of functionality for you. And if you find the key variable, please let us know.
Sincerely,


Michael Johnson
QA Supervisor
MakeMusic!

Back to Top

Norman
Registered Member

Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to NormanAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Nov 2003
Total Posts : 12
 
   Posted 5/4/2004 1:38 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Robert,

Like Thomas, I'm running Windows XP SP1 for the version where the editor doesn't work.
And havn't touched my trusty W98 with the old version of Finalescript.

Like Thomas said, I can copy a script with ctrl+shift+end into a text editor, change it, and paste
it back into Finalescript. The script runs but displays line endings with those two funny virtical bars.
Maybe my XP machine has picked up a virus from the internet, but everything else seems OK.

Thank you for creating Finalescript!

Norman
Back to Top

Robert P.
Registered Member



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to Robert P.AIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Apr 2004
Total Posts : 1691
 
   Posted 5/2/2004 5:45 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Norman,

Which version of Windows are you running ? (on your 2 machines) Same as Thomas for the version that doesn't work?

Just trying to get some clues...

Best regards,
Robert
Back to Top

Norman
Registered Member

Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to NormanAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Nov 2003
Total Posts : 12
 
   Posted 5/1/2004 9:11 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
Hello!

I ran into exactly the same problem. The Finalescript editor having some kind of difficulty with line endings.
I suspect a system problem because reinstalling Finale 2004b from scratch, even with the old version of the
Finalescript plug-in, didn't fix anything! The FinaleScript.dat file is also OK.

Fortunately the old version on my other machine works fine so I use that for now.

Norman
Back to Top

Thomas Hansen
Horn Player, Freelancer Engraver.



Email Address Not AvailableClick to visit Thomas Hansen's website.Send a Private Message to Thomas HansenAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Mar 2001
Total Posts : 66
 
   Posted 4/28/2004 2:04 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Michael,

It´s still not working. I re-installed the old version, re-installed the original dat file, changed plugin´s location... No results! I even tried to run finalescript without a dat file, with no results. It seems that all <enter> characters are being shown as that strange double-bar that appears on the attachment. If I delete it, the horizontal scrollbar appears, but lets me scroll only between the start of the line and the next "double-bar".

I´m lost. Any clue?

Cheers,

Thomas


----------------------------------------------------------

Helloooooooooooooo... Curse!

Back to Top

Michael Johnson
Registered Member



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to Michael JohnsonAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Mar 2004
Total Posts : 1317
 
   Posted 4/27/2004 2:02 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Hi Thomas--
I am running XP with the new version and I don't see the problem.
Here are some things to try:
The Scripts are stored in a file called FinaleScript.dat in your Finale 2k4b components folder. You could replace that file with the one that came on your Finale 2k4 CD and verify whether the .dat file is corrupt.
You can get back to the old plug-in (in fact you can have both of them in the Plug-ins folder at the same time). I would make a folder called "2k4 FS pi" and place it in your 2k4b plug-ins folder, copy the FS pi from the Extras folder on the 2k4 cd to this folder. Then start Finale 2k4b and see if the behavior is also there.
This is the first report of this issue, so I suspect either the .dat file is messed up or the download of the plug-in was wacky.
Keep me posted if problems continue


Michael Johnson
QA Supervisor
MakeMusic!

Back to Top

Thomas Hansen
Horn Player, Freelancer Engraver.



Email Address Not AvailableClick to visit Thomas Hansen's website.Send a Private Message to Thomas HansenAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Mar 2001
Total Posts : 66
 
   Posted 4/26/2004 8:19 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
Robert,

I just reinstalled the FinaleScript Plugin, with the same results. I´m using Fin2004b on Windows XP SP1. I´m sending an attachment with a screenshot of the problem.

Thanks,

Thomas


----------------------------------------------------------

The great difference between God and a conductor: God doesn´t think he is a conductor...


Image Attachment :
Image Preview
finscript.jpg
  122KB (image/jpeg)
This image has been viewed 363 time(s).
Back to Top

Robert P.
Registered Member



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to Robert P.AIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Apr 2004
Total Posts : 1691
 
   Posted 4/23/2004 5:34 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Hi Thomas,

Just to be sure, I just redownloaded the latest FinaleScript plug-in file that was posted (dated 4/16/04). I opened the script editor fine, and could create new script smoothly, and could not reproduce any of the issues you mentioned. Scroll bars and Enter (=line feed) key work fine, and no weird character on screen.

Which OS are you running?

Has anybody else been experiencing such weird things with the new version of FS?

Best regards,
Robert
Back to Top

Thomas Hansen
Horn Player, Freelancer Engraver.



Email Address Not AvailableClick to visit Thomas Hansen's website.Send a Private Message to Thomas HansenAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Mar 2001
Total Posts : 66
 
   Posted 4/23/2004 8:08 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
Folks, I just downloaded and installed the new Finalescript. I opened it and tried to read one of the scripts, but the script editor is broken: I could only read the first line of the script, the scrollbars are not working and there is a strange symbol (like two vertical large bars) at the beginning of the line (replacing the CR+LF sequence). If I select all the script (Ctrl+Shift+End), copy and paste it to a Notepad, I can see the whole script. The problem occurs when creating new scripts, also (<enter> does not work, neither the scrollbars). Apparently, the scripts are working (I tested just one, and it was ok).

Any workaround for this? I wish I had made a backup of the old version... sad

Thomas


----------------------------------------------------------

The great difference between God and a conductor: God doesn´t think he is a conductor...

Back to Top
You cannot post new topics in this forum. You cannot reply to topics in this forum. Printable Version
   
Forum Information
Currently it is Saturday, December 14, 2019 2:46 AM (GMT -6)
There are a total of 403,820 posts in 58,165 threads.
In the last 3 days there were 0 new threads and 0 reply posts. View Active Threads