Finale SmartMusic
  Home | Log In | Register | Search | Help
   
MakeMusic Forum > Public Forums > SmartMusic - FORUM HAS MOVED! > Problems with use on Mac with Parental Controls enabled after latest update  Forum Quick Jump
 
You cannot post new topics in this forum. You cannot reply to topics in this forum. Printable Version
[ << Previous Thread | Next Thread >> | Show Newest Post First ]

groomscar
Registered Member

Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to groomscarAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Jan 2011
Total Posts : 8
 
   Posted 2/23/2013 5:29 PM (GMT -5)    Quote This PostAlert An Admin About This Post.
Do any of you use Parental Controls on the computers you have for students at school to limit what programs they have access to?

We have Macs, running 10.5. I have five that are out of eyesight, so I set up the student login to block access to all but the programs they need for my band class (Smartmusic, Garageband, Safari - but limited only to whitelisted sites, Finale Notepad, etc.) Once I downloaded the latest 2013c version, I encountered a problem I'd never had before and wasn't able to solve with Smartmusic tech help - at least not before my own system's technology department swatted my hands for messing with things I wasn't authorized to change, like permissions. Yesterday my tech person finally got to me. We weren't able to completely resolve it, but he thinks he found an explanation.

After my update, when students tried to open SM under the student computer account, they got the message "Smartmusic isn't allowed..." with the options to override with teacher/admin login and password, as usual for anything. Yet, when I would try to override it, the message would just keep popping back up and not take effect. So I went to parental controls to make sure my selections were intact for the student account. Smartmusic did not show up in the list of applications to select at all. It does still appear in the main list of applications in the main finder, just does not appear in the list in parental controls. We tried everything - changing permissions of all sorts in various ways - to the applications folder, just to Smartmusic, etc. Tried uninstalling and reinstalling SM. Nothing has worked.

My local tech guy yesterday was stumped, (and for a change couldn't find anything to blame on me!) He did some web searching and concluded that this version of SM is created as a "wrapper application" and is vulnerable to a known bug in Mac OS 10.5 and beyond which makes it unrecognizable in the parental controls. I have no idea really, not understanding the concept of a "wrapper app" any more than he explained to me then. The solution for now is to enable all programs on the student login, and if I wish something to be unavailable to the student, go to the permissions of the specific program and change it there. Very time consuming, so I don't know that I'll get around to setting them.

Has anyone else experienced anything like this?
Back to Top
You cannot post new topics in this forum. You cannot reply to topics in this forum. Printable Version
   
Forum Information
Currently it is Sunday, July 21, 2019 4:51 AM (GMT -5)
There are a total of 407,481 posts in 58,781 threads.
In the last 3 days there were 0 new threads and 0 reply posts. View Active Threads