Finale SmartMusic
  Home | Log In | Register | Search | Help
   
MakeMusic Forum > Public Forums > Finale - Windows - FORUM HAS MOVED! > WARNING UPDATE! Do Not Run the Windows 25 Upgrade on Windows 7  Forum Quick Jump
 
You cannot post new topics in this forum. You cannot reply to topics in this forum. Printable Version
63 posts in this thread.
Viewing Page :
 1  2  3 
[ << Previous Thread | Next Thread >> | Show Newest Post First ]

Ron.
Composer



Email Address Not AvailableClick to visit Ron.'s website.Send a Private Message to Ron.AIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Mar 2003
Total Posts : 8828
 
   Posted 10/19/2016 2:34 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
I just responded positively to the request within Finale 25 to install a maintenance release. I did. Not only did the upgrade fail (because of a missing DLL, according to the error message), but it removed Finale 25 from my system! I can't believe this! I will now have to download and reinstall Finale 25 and recover all of my customizations--which are considerable.

This is the first time in my 30-plus years of computer experience that a simple upgrade has removed the previous version entirely.

(Update: This issue appears to be limited to Windows 7.)


Finale 25

GPO5, JaBB3, GIO, COMB2, GWI, GIFF, Steinway Basic.

Windows 7; 10 GB RAM.

www.composeforums.com

Post Edited (Ron.) : 10/27/2016 11:56:42 AM (GMT-5)

Back to Top

jange
Registered Member

Email Address Not AvailableClick to visit jange's website.Send a Private Message to jangeAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Oct 2013
Total Posts : 53
 
   Posted 10/19/2016 3:09 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
The installation went fine on my Windows 10. I did not notice any customizations lost so far.
Configuration Files, Font Annotations not changed.
The only thing that I noticed that was lost was the Finale icon on the Windows task bar.
I think, they changed the program installation directory from Finale to Finale25. That's why it wasn't there anymore.
I wasn't using that directory for customizations or other files.
But maybe if you had put something into Program Files/Finale, it could get lost.

So be at least careful.

Jan

Post Edited (jange) : 10/19/2016 3:18:41 PM (GMT-5)

Back to Top

Lawson D
MakeMusic Customer Success



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to Lawson DAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Jun 2015
Total Posts : 90
 
   Posted 10/19/2016 3:16 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Hi Ron,

That certainly does sound like the updater actually failed and is not working as expected and reported. So far, we have not had widespread reports of the updater failing, so I do expect this to work for you! By any chance, was Finale v25 open when running the updater? Also, just a quick clarification, since this is an update and not a new version of Finale, the updater will replace Finale v25 with Finale v25.1 jsut as was the case with maintenance updates in previous versions of Finale.

Since the updater ran into some unforeseen obstacle, I would recommend downloading the full installer from your MakeMusic account and running that installer. This will ensure that you are getting all the necessary components to run the latest version of Finale. I would recommend restarting your computer and then closing any programs before running the installer, just to be safe.

If you are getting the DLL error again, please send along a screenshot of the error and we can assess further.


Thanks!


Lawson D.
Notation/Garritan Product Specialist
MakeMusic, Inc



These on-line forums are intended for the exchange of ideas among the users of MakeMusic products. If you'd like individual help from our Customer Success staff, please contact us here.

Back to Top

jange
Registered Member

Email Address Not AvailableClick to visit jange's website.Send a Private Message to jangeAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Oct 2013
Total Posts : 53
 
   Posted 10/19/2016 3:21 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Hi Lawson,

I don't know what the installer is deleting on Windows, but it definitely installed into a different directory (C:\Program Files\Finale25) than the original v25 installation (C:\program Files\Finale) and removed all Finale files from the original directory. Maybe it deleted other files as well ?

Jan
Back to Top

Lawson D
MakeMusic Customer Success



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to Lawson DAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Jun 2015
Total Posts : 90
 
   Posted 10/19/2016 3:33 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Hi Jan,

Thanks for letting me know.

It seems like you are actually seeing some unexpected behavior as well. I do expect the updater to remove the program components at C:\Program Files\Finale (except for the Data folder to maintain VST configurations), but then it should replace the removed components with the updated versions so you wind up using Finale v25.1. It will not overwrite preferences and configuration files in AppData. The fact that it is creating a new directory on your end is definitely odd. This happened when you were just using the default options in the updater installation process, correct?


Lawson D.
Notation/Garritan Product Specialist
MakeMusic, Inc



These on-line forums are intended for the exchange of ideas among the users of MakeMusic products. If you'd like individual help from our Customer Success staff, please contact us here.

Back to Top

jange
Registered Member

Email Address Not AvailableClick to visit jange's website.Send a Private Message to jangeAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Oct 2013
Total Posts : 53
 
   Posted 10/19/2016 3:41 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
yes, default installation options
yes, AppData\.. was still fine and not removed.
no, the Data folder was not removed, but it only contained one file after the installation (GIFF.soundmap) while the new Data folder contained several files. So I assume a few files were also deleted from the Data folder.

Post Edited (jange) : 10/19/2016 3:44:09 PM (GMT-5)

Back to Top

Zuill
"The Troll"



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to ZuillAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Oct 2003
Total Posts : 29077
 
   Posted 10/19/2016 4:05 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
I haven't looked at v25 yet. However, I have a question. If one downloads and installs the trial version at this point, is it v25 or v25.1?

Zuill


"When all is said and done, more is said than done."
 
Win 7 64bit, 2011b, 2012c, 2014d, 2014.5 
 
Favorite Forum quote: "Please, everybody, IGNORE THE TROLL!"

Back to Top

gogreen
Registered Member



Click to send gogreen email.Click to visit gogreen's website.Send a Private Message to gogreenAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Dec 1999
Total Posts : 1618
 
   Posted 10/19/2016 4:41 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
I should have heeded your advice, Ron. The installation failed. It rolled back after I got the attached error message, but not before deleting the .exe file, leaving only the data and plug-ins folder in Program Files\Finale.


Arthur J. Michaels

/www.facebook.com/composerarthurjmichaels

Finale 2000, 2001, 2003, 2005, 2006, 2007, 2011b.r2, 2014d, 2014.5, Finale 25
Core i7 860 @ 2.80 GHz, 8.0 GB RAM, Windows 10 Home x64
Garritan COMB2, GPO4, GPO5, Aria Player 1.872, Audacity 2.1.2
Dell 2408 WFP, 1920x1200
M-Audio Delta Audiophile 2496
Casio WK-3000
M-Audio AV40 monitors
AKG K-240 Studio headphones
Brother MFC-L2740DW printer


Image Attachment :
Image Preview
error.PNG
  6KB (image/png)
This image has been viewed 173 time(s).
Back to Top

Derrek
Registered Member

Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to DerrekAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Dec 2009
Total Posts : 2347
 
   Posted 10/19/2016 4:54 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Wow, I guess I'm lucky. My upgrade went without a hitch. Finale folder name stayed intact, and I lost nothing I can discover so far. I did make sure to shut finale down before running the upgrade software.


Finale 2014.5, Finale 25 - Windows 7 (64-bit)
GPO 5, JABB 3, World Instruments
TG Tools Full, (Sonar Platinum)

“Outside of a dog, a book is a man’s best friend. Inside of a dog it’s too dark to read.” — Groucho Marx

Back to Top

Ron.
Composer



Email Address Not AvailableClick to visit Ron.'s website.Send a Private Message to Ron.AIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Mar 2003
Total Posts : 8828
 
   Posted 10/19/2016 5:55 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
I do not have a Finale25 folder. The updater emptied out the Finale folder (under "Program Files"). Apparently, it left the files under "Appdata" alone, so I did not lose the .ini files as I had feared. I took a screen shot of the error box. Attached.

My confidence in MM has been badly shaken.


Finale 25

GPO5, JaBB3, GIO, COMB2, GWI, GIFF, Steinway Basic.

Windows 7; 10 GB RAM.

www.composeforums.com


Image Attachment :
Image Preview
Missing dll.png
  244KB (image/png)
This image has been viewed 215 time(s).
Back to Top

gogreen
Registered Member



Click to send gogreen email.Click to visit gogreen's website.Send a Private Message to gogreenAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Dec 1999
Total Posts : 1618
 
   Posted 10/19/2016 5:59 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
I manually removed leftover files, mainly in Programdata, which the installer didn't remove. I then downloaded and successfully installed the full installer. By the way, Zuill, the full installer does say 25.1, as does the Help > about Finale window (25.1.0.182).


Arthur J. Michaels

/www.facebook.com/composerarthurjmichaels

Finale 2000, 2001, 2003, 2005, 2006, 2007, 2011b.r2, 2014d, 2014.5, Finale 25
Core i7 860 @ 2.80 GHz, 8.0 GB RAM, Windows 10 Home x64
Garritan COMB2, GPO4, GPO5, Aria Player 1.872, Audacity 2.1.2
Dell 2408 WFP, 1920x1200
M-Audio Delta Audiophile 2496
Casio WK-3000
M-Audio AV40 monitors
AKG K-240 Studio headphones
Brother MFC-L2740DW printer

Back to Top

CraigP
Registered Member

Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to CraigPAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Apr 2013
Total Posts : 313
 
   Posted 10/19/2016 7:33 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
The upgrade applied with no issues. However, now Finale crashes anytime I try to apply an expression. I take the same file back to 2014.5 and no problems.

I'd definitely stay away from this until the problems are sorted out.
Back to Top

Zuill
"The Troll"



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to ZuillAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Oct 2003
Total Posts : 29077
 
   Posted 10/19/2016 8:09 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
I don't see a new blog post about this issue. Do you think they will do that?

Zuill


"When all is said and done, more is said than done."
 
Win 7 64bit, 2011b, 2012c, 2014d, 2014.5 
 
Favorite Forum quote: "Please, everybody, IGNORE THE TROLL!"

Back to Top

CraigP
Registered Member

Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to CraigPAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Apr 2013
Total Posts : 313
 
   Posted 10/20/2016 9:14 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
Is anybody getting the system crash problem when trying to assign an expression? The system crashes when I have the expression tool selected and I click anywhere.
Back to Top

Derrek
Registered Member

Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to DerrekAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Dec 2009
Total Posts : 2347
 
   Posted 10/20/2016 9:36 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
I just checked, and no. The only change I have noticed is that the recent files in the Startup menu (but not in the opening Finale screen) have been cleared.


Finale 2014.5, Finale 25 - Windows 7 (64-bit)
GPO 5, JABB 3, World Instruments
TG Tools Full, (Sonar Platinum)

“Outside of a dog, a book is a man’s best friend. Inside of a dog it’s too dark to read.” — Groucho Marx

Back to Top

CraigP
Registered Member

Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to CraigPAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Apr 2013
Total Posts : 313
 
   Posted 10/20/2016 9:46 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
I tested by creating a new score from scratch. That also crashed as soon as I tried to use the expression tool anywhere. It crashes as soon as I double-click, before seeing the expression dialog.

I had set a restore point immediately before installing the 25.1 patch. I restored back to that point. That revered to V25, but now V25 has the same problem. SO it appears I am going to have to wipe out V25 altogether and go back through that install process. Fortunately this did not corrupt 2014.5.
Back to Top

Motet
Isorhythmic



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to MotetAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Dec 2002
Total Posts : 12849
 
   Posted 10/20/2016 10:15 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
Try resetting preferences.


Finale 2014.5, 2011b, 2005, TGTools
Windows 7, MIDI input
Finale Transposition Chart

Back to Top

Lawson D
MakeMusic Customer Success



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to Lawson DAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Jun 2015
Total Posts : 90
 
   Posted 10/20/2016 10:58 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
CraigP,

Motet is on the right track. Crashing when using the Expression tool can occur and when it does, it is best to reset preferences. This has been known to happen from time to time on the Windows side and is something that I had thought was a thing of the past. I will be sure to start keep tabs on this one.

Fortunately, I do not think this was a result of the updater, but perhaps an old issue that has resurfaced. You can easily reset preferences in Finale v25 by saving your work, opening the Preferences dialog box (Edit > Preferences), and then clicking the Reset All Preferences button.


Lawson D.
Notation/Garritan Product Specialist
MakeMusic, Inc



These on-line forums are intended for the exchange of ideas among the users of MakeMusic products. If you'd like individual help from our Customer Success staff, please contact us here.

Back to Top

andyoc
Registered Member

Click to send andyoc email.Personal Homepage Not AvailableSend a Private Message to andyocAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Feb 2005
Total Posts : 78
 
   Posted 10/20/2016 11:10 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
Updated to 25.1 here.
Moved the FinaleUpdaterSetup.exe into the C:/Program Files/Finale folder, and ran from there.
So far, 25.1 is running fine, and loading all Finale files.

Expressions working correctly.

Cheers!


Andy O'Callaghan
AOC Music Services Ltd.
Dublin
Rp of Ireland

Finale All versions to 25
i7 2600k/ 16G / W10 Home
Nuendo 7 / Cubase 8.5 / Wavelab 7
RME MADI - RAYDAT
VSL ENSEMBLE PRO 6 - Running on Master + 2 slaves

Back to Top

Zuill
"The Troll"



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to ZuillAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Oct 2003
Total Posts : 29077
 
   Posted 10/20/2016 11:27 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
So, am I correct in guessing one can download the update installer or not? If so, does it seem that downloading it first gives better results than running it remotely?

Zuill


"When all is said and done, more is said than done."
 
Win 7 64bit, 2011b, 2012c, 2014d, 2014.5 
 
Favorite Forum quote: "Please, everybody, IGNORE THE TROLL!"

Back to Top

Ron.
Composer



Email Address Not AvailableClick to visit Ron.'s website.Send a Private Message to Ron.AIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Mar 2003
Total Posts : 8828
 
   Posted 10/20/2016 11:33 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
I downloaded it then ran it, following the instructions.


Finale 25

GPO5, JaBB3, GIO, COMB2, GWI, GIFF, Steinway Basic.

Windows 7; 10 GB RAM.

www.composeforums.com

Back to Top

CraigP
Registered Member

Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to CraigPAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Apr 2013
Total Posts : 313
 
   Posted 10/20/2016 12:57 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Lawson D said...
Motet is on the right track. Crashing when using the Expression tool can occur and when it does, it is best to reset preferences. This has been known to happen from time to time on the Windows side and is something that I had thought was a thing of the past. I will be sure to start keep tabs on this one.



Thanks. That procedure cleared up the V25.0 version I reverted back to using the Windows restore point. I then went through the V25.1 patch again and this time there were no issues with the expression tool (and no need to reset the preferences.)

The only thing I think that might have been irregular in my original update process is that I saved the FinaleUpdaterSetup.exe on network-attached storage (as usual). I had double clicked on that NAS location to launch the updater. But running it that way takes an eternity (not a Finale issue. All large updaters crawl this way.) So I copied the updater to my desktop, which just takes a few seconds, and ran the updater from there. While this desktop-based updater was running, the NAS-based updater was still crawling along in the background. The desktop-based update finished quickly without any error indications. Roughly 10 minutes later, the NAS-based updater popped up the "Welcome to the Finale Bundle Update Setup Wizard" window, which I canceled.

I assumed that the updater did nothing to the application prior to the "Welcome" window appearing, but perhaps there were some file collisions that caused the preferences file to become corrupted. So I would suggest that you look at the possibility of problems that can happen if multiple instances of the updater are launched simultaneously. I emphasize that the NAS-based one never proceeded beyond the welcome screen, so if this is the issue, something must have happened BEFORE the welcome screen appears. If there is such a file collision, that could probably account for a lot of problems in the past, as this is an easy mistake to make, especially on large updaters that don't immediately pop up a welcome screen. Perhaps there is some kind of lock that you can put in place to prevent 2 setups from running simultaneously.

Post Edited (CraigP) : 10/20/2016 1:27:52 PM (GMT-5)

Back to Top

DCrocker
Registered Member



Email Address Not AvailableClick to visit DCrocker's website.Private Messaging Not AvailableAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Mar 2000
Total Posts : 511
 
   Posted 10/21/2016 6:39 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
v. 25.1 update worked fine - and is working fine - on the Windows 7 box.
On the Windows 10 box, I got the "missing DLL" message. Searched that machine for that file, found it, and copied it to the /windows/system32 directory, which is where it lives on the Windows 7 machine.
>> It's the sort of solution that would have worked in 1995 :-)
Now I just get a "can't start the program" message. Possibly a different version of the same DLL?
Deleting that copied DLL, I am back to the "missing DLL" message. The file in question is mfc140u.dll, BTW.

dean


Finally using FinWin 2014 on Windows 7 for everything, despite the irritations…
(Previously used everything back to version 2.0.1)

Back to Top

Ron.
Composer



Email Address Not AvailableClick to visit Ron.'s website.Send a Private Message to Ron.AIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Mar 2003
Total Posts : 8828
 
   Posted 10/21/2016 10:01 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Support suggested I download the entire fresh copy the of Finale 25.1 program instead of just the patch update. I did that, but am afraid to run it as I do not want to spend the rest of the weekend rebuilding all my customizations. So, I plan to back up everything remotely related to Finale before I proceed.

The last time something like this happened was when I installed a maintenance patch for Finale 2004 and I was unable to use Finale at all. Fortunately, in those days, I had a CD copy of the original before the patch, so I was able to revert after wiping my disk.


Finale 25

GPO5, JaBB3, GIO, COMB2, GWI, GIFF, Steinway Basic.

Windows 7; 10 GB RAM.

www.composeforums.com

Back to Top

Motet
Isorhythmic



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to MotetAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Dec 2002
Total Posts : 12849
 
   Posted 10/21/2016 10:14 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Do you know if the DLL was indeed missing, or is the PATH variable not being set up correctly?


Finale 2014.5, 2011b, 2005, TGTools
Windows 7, MIDI input
Finale Transposition Chart

Back to Top
You cannot post new topics in this forum. You cannot reply to topics in this forum. Printable Version
63 posts in this thread.
Viewing Page :
 1  2  3 
   
Forum Information
Currently it is Saturday, December 7, 2019 11:18 AM (GMT -6)
There are a total of 403,820 posts in 58,165 threads.
In the last 3 days there were 0 new threads and 0 reply posts. View Active Threads