Finale SmartMusic
  Home | Log In | Register | Search | Help
   
MakeMusic Forum > Public Forums > Finale - Macintosh - FORUM HAS MOVED! > Left Channel Audio Interface Bug Digital Workaround  Forum Quick Jump
 
You cannot post new topics in this forum. You cannot reply to topics in this forum. Printable Version
[ << Previous Thread | Next Thread >> | Show Newest Post First ]

encephalon
Registered Member

Email Address Not AvailableClick to visit encephalon's website.Send a Private Message to encephalonClick to Add encephalon@mac.com to Your AIM Buddy List.ICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Aug 2001
Total Posts : 315
 
   Posted 11/20/2008 4:28 PM (GMT -5)    Quote This PostAlert An Admin About This Post.
I have found a workaround for the dreaded Left Channel Audio Interface Bug. I do not know if this works for the "no channel" audio interface bug, nor can I confirm that it will work with every system and configuration. Here are my specs:

PowerMac G5 Dual 2.7
4.5G RAM
Mac OS X Leopard 10.5.5
Finale 2008b
Focusrite Saffire Pro 26 i/o (Firewire multi-channel Interface)

A recap of this bug:

Finale 2008 and above does not play both channels of application-generated audio through many, if not most, external audio interfaces. The interfaces most affected seem to be Firewire-based, but there are some USB interfaces that don't work either. In some cases, only the left channel audio will play, and in other cases, neither channel will play.

Audio from the Quicktime Musical Instruments outputs will play properly through external interfaces, but both the Smart Music and Audio Unit output selections result in this bug. The previous workaround involves an ugly 20th-century solution: physically patching the output of your computer (low quality DA to mini-jack, or light-pipe) back into your audio interface, digitally routing that output into your main output mix.

This is clearly a MakeMusic problem, and is not related to the operating system or the external interfaces. MakeMusic has acknowledged this issue and "is working on a solution." We have heard nothing of this pending solution since their original acknowledgement, and even the newest version of Finale (2009) does not address this issue.

I post this solution with a tinge of fear that MakeMusic will never develop a solution to this example of poor programming. Now that a 3rd party solution exists, they have no motive for devoting resources to cleaning up their mess. Based on their recent development history, I am doubtful that they will fix it themselves. Ever.

Enough soapbox -- on to the solution!

To fix this problem, you need to download the handy (and free) tool Soundflower from Cycling '74. This utility allows you to route audio digitally between applications and interfaces. Once installed, it will become a viable input and output choice along with System Audio, Built In Audio, your interface, etc.

The Soundflower digital interface will place an icon in your menu bar (you can remove it if you like). There are two interface options: 2-Channel and 16-Channel. Since I use Finale in Stereo configuration, I chose 2-channel. In Soundflower, assign channel 1 to your interface output #1, and channel 2 to output #2 (may already be done so by default).

Select "Soundflower (2ch)" as your audio output in the "Audio Setup" box in Finale.

See the images I've attached.

You should hear Finale in Stereo out of your audio interface. If not, go back into Soundflower and "fiddle" with the settings, bringing them back to those I've listed above.

Feel free to follow up with questions, and please post your success and failure with other audio interfaces and Finale versions.

Enjoy!


encephalon
Lush Music


Image Attachment :
Image Preview
SF-Menu.png
  15KB (image/png)
This image has been viewed 129 time(s).
Image Attachment :
Image Preview
SF-Menu-2.png
  38KB (image/png)
This image has been viewed 125 time(s).
Image Attachment :
Image Preview
Finale-Audio-Menu.png
  13KB (image/png)
This image has been viewed 143 time(s).
Back to Top

encephalon
Registered Member

Email Address Not AvailableClick to visit encephalon's website.Send a Private Message to encephalonClick to Add encephalon@mac.com to Your AIM Buddy List.ICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Aug 2001
Total Posts : 315
 
   Posted 11/20/2008 5:08 PM (GMT -5)    Quote This PostAlert An Admin About This Post.
Apparently, this has been fixed in Finale 2009a and above.

Yeah, MakeMusic!

For those of use who still use Finale 2008, this workaround is our only solution. Maybe I'll upgrade now. =)


encephalon
Lush Music

Back to Top
You cannot post new topics in this forum. You cannot reply to topics in this forum. Printable Version
   
Forum Information
Currently it is Thursday, August 18, 2022 10:16 PM (GMT -5)
There are a total of 403,820 posts in 58,165 threads.
In the last 3 days there were 0 new threads and 0 reply posts. View Active Threads