Finale SmartMusic
  Home | Log In | Register | Search | Help
   
MakeMusic Forum > Public Forums > Finale - Macintosh - FORUM HAS MOVED! > Font Annotation in v25 (probably 2014 too)  Forum Quick Jump
 
You cannot post new topics in this forum. You cannot reply to topics in this forum. Printable Version
[ << Previous Thread | Next Thread >> | Show Newest Post First ]

Ward Baxter
Mercenary of Music



Click to send Ward Baxter email.Click to visit Ward Baxter's website.Send a Private Message to Ward BaxterAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Oct 1999
Total Posts : 280
 
   Posted 8/17/2016 3:44 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
2012 and earlier files are opening with articulations and slurs offset too far vertically in the Partita font.

The 2012 font annotation file for Partita is incompatible with v25. This appears to be true with 2014 and 2014.5 as well. I’m considering manually editing the font annotation in order to match, but the characters even appear differently. In 2012 and earlier, font annotations were referenced by character number where in newer versions they are referenced by glyph. For example, a treble clef is character 38 in Finale 2012 and character & (ampersand) in v25. Additionally, missing glyphs appear blank in 2012 and as large question marks in v25.

The font annotation needs to match 2012 precisely. We have tens of thousands of stable 2012 and earlier files that need to look the same on every machine they’re opened upon. I can auto-annotate, but I’m not quite sure what that algorithm does. When comparing the two versions side by side, the Font Reference Lines are dramatically different. Is there a way of adjusting that value? Any help in this is greatly appreciated. Thanks.


Ward Baxter
Finale 2012c (primary), 2014.5 (testing), 2014d, 2002 (stability) and every version since 3.0
TGTools, Forza, Patterson...all the goodies!
Mavericks, Yosemite/El Capitan (testing), Windows XP (yes, XP)

Back to Top

Ward Baxter
Mercenary of Music



Click to send Ward Baxter email.Click to visit Ward Baxter's website.Send a Private Message to Ward BaxterAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Oct 1999
Total Posts : 280
 
   Posted 8/17/2016 3:58 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
I should also add that when I switched default fonts to make sure it was a font annotation issue with Partita, that Vienna was not available in my font list. In fact, all of the V fonts aren't there. When I open I file with Vienna already set up as default, all of the V fonts are there. Neat feature…


Ward Baxter
Finale 2012c (primary), v25 and 2014.5 (testing), 2002 (stability) and every version since 3.0
TGTools, Forza, Patterson...all the goodies!
El Capitan, Windows XP (yes, XP)

Back to Top

Michael Johnson
Registered Member



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to Michael JohnsonAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Mar 2004
Total Posts : 1317
 
   Posted 8/17/2016 4:43 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Hi Ward:
With Finale v25 not running, copy your Partita.FAN file (and any other fonts you use) from HD/Library/Application Support/MakeMusic/Finale 2012/Font Annotation to HD/Library/Application Support/MakeMusic/Finale/Font Annotation. Start Finale v25 and your files should be fine.
Probably a good idea to restart your mac if you're seeing missing characters.

Cheers,
Michael


Michael Johnson

MacBook Pro
10.11
2.6 GHz Intel Core i7
8 GB RAM

Back to Top

Ward Baxter
Mercenary of Music



Click to send Ward Baxter email.Click to visit Ward Baxter's website.Send a Private Message to Ward BaxterAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Oct 1999
Total Posts : 280
 
   Posted 8/17/2016 5:36 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Thanks Michael, already tried that. I did it for the User folder as well, along with updating the MacSymbolFonts.txt file. We have 6 licenses for Finale 2014.5 that this same issue is occurring on. All 34 licenses for 2012 use the same font annotation. The Reference Line value change seems to be the culprit. Any way to adjust that?


Ward Baxter
Finale 2012c (primary), v25 and 2014.5 (testing), 2002 (stability) and every version since 3.0
TGTools, Forza, Patterson...all the goodies!
El Capitan, Windows XP (yes, XP)

Back to Top

Michael Johnson
Registered Member



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to Michael JohnsonAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Mar 2004
Total Posts : 1317
 
   Posted 8/17/2016 6:04 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Hi Ward:
Darn. What a bummer. Sorry my suggestions didn't help. I don't have a quick solution and I don't know that just editing the Reference Line Value will get you what you want. Let me ask around.

Cheers,


Michael Johnson

MacBook Pro
10.11
2.6 GHz Intel Core i7
8 GB RAM

Back to Top

Michael Johnson
Registered Member



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to Michael JohnsonAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Mar 2004
Total Posts : 1317
 
   Posted 8/17/2016 8:14 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Hi Ward:

My colleagues and I suspect it is an old PS font with no header information and no Unicode codepoints. We had to clean up Finale starting with 2014 to following the guidelines from Apple on supporting fonts. So, it does make sense that Finale 2012 would behave differently than 2014 & v25. If you would be willing to Private Message me a copy of the font and your files, we could confirm.

As for FAN files, another suspicion is that they aren't being seen by Finale at all, so editing the fan file will accomplish nothing. A screen shot sure would confirm. Just out of curiosity, in Preferences - Folders is Finale properly directed to look at your FAN files?

Cheers,
Michael


Michael Johnson

MacBook Pro
10.11
2.6 GHz Intel Core i7
8 GB RAM

Back to Top

Ward Baxter
Mercenary of Music



Click to send Ward Baxter email.Click to visit Ward Baxter's website.Send a Private Message to Ward BaxterAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Oct 1999
Total Posts : 280
 
   Posted 8/17/2016 9:01 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Thanks, Michael. I will PM you. Just so it's here if anyone else is searching, to answer your question about prefs, yes. I tried arbitrarily setting the location and going with the default (unchecked) option. Neither had an effect. Other FAN files are loading. I have no doubt that it is a font issue, but it is a font issue that effects 10,000 files on our servers and the font creator disappeared quite some time ago, unfortunately.


Ward Baxter
Finale 2012c (primary), v25 and 2014.5 (testing), 2002 (stability) and every version since 3.0
TGTools, Forza, Patterson...all the goodies!
El Capitan, Windows XP (yes, XP)

Back to Top

Andy2000
Registered Member

Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to Andy2000AIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Jan 2005
Total Posts : 125
 
   Posted 8/18/2016 3:20 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
I don't know if this is related, but I've twice with different font each time opened a file for the first time in F25 and been prompted to auto-generate font annotation. When I did, it put my smart shapes about 8 spaces too high vertically until I manually went to Finale Menu to do it from the Edit submenu in preferences. Auto-generate from the dialog generated by opening a file using a font with no annotation does not work in F25.
Back to Top
You cannot post new topics in this forum. You cannot reply to topics in this forum. Printable Version
   
Forum Information
Currently it is Wednesday, November 13, 2019 10:49 PM (GMT -6)
There are a total of 403,820 posts in 58,165 threads.
In the last 3 days there were 0 new threads and 0 reply posts. View Active Threads