Finale SmartMusic
  Home | Log In | Register | Search | Help
   
MakeMusic Forum > Public Forums > Finale - Macintosh - FORUM HAS MOVED! > Finale 25.x - two bugs  Forum Quick Jump
 
You cannot post new topics in this forum. You cannot reply to topics in this forum. Printable Version
[ << Previous Thread | Next Thread >> | Show Newest Post First ]

Juraj Bartos
Registered Member

Click to send Juraj Bartos email.Click to visit Juraj Bartos's website.Send a Private Message to Juraj BartosAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Jan 1999
Total Posts : 492
 
   Posted 10/23/2016 9:15 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
Hello everyone,
there are still two bugs in Finale 25.x, one of them new and one quite old.
I discussed both with MM support, no progress so far, so I try it here again.
The new one:
- after opening an older file, created by Finale 2012 and older, which contains linked graphics in Tiff format, there is no way to continue my work on Finale 25.x. The Dialog box "This type of TIFF file is not supported for import." pops up continuously and I have to quit Finale 25.x without any chance to solve it. There is a simple workaround for this - open the file in 2014.5 and make the TIFF file embedded, but anyway, without 2014.5 the file would be unusable.

The old one:
- Staff Styles like Slash or Rhythmic Notation appear in Score only, in linked parts they appear as normal notation and this is annoying and time consuming bug. I could find no other workarounds than manual checking between the Part and the Score and make the Staff Style visible in linked Part as well, or checking every time "Use Selected Staff Style for Score and Parts" in context menu after selecting the Staff Style in the Score, even after copying between the Staves (Guitar and Piano in my case), which is a little nightmare.

See the attachments.

Any solutions?

Thanks.


Juraj Bartos, www.serenaders.sk

Finale 2001-2012c, Finale 2014.5, Finale 25
Tobias Giesen TGTools, Patterson Plugins, Jari Williamsson Plugins
Pro Tools 11.3.1, Waves Platinum, Sibelius 7,

MacBook Pro 15" 2,6 GHz Intel Core i7, 16 GB RAM, Mac OS X 10.10.5 (retina with SSD HD)
Korg Micro Key 61/49/25, M-Audio Keystation Mini 32

Finale 2014d, StaffPad
Microsoft Surface Pro 3 i7, 8GB RAM, 512GB SSD, Win 10

Post Edited (Juraj Bartos) : 10/23/2016 4:26:30 PM (GMT-5)


Image Attachment :
Image Preview
Bug in TIFF import Finale 25.jpg
  801KB (image/jpeg)
This image has been viewed 436 time(s).
Image Attachment :
Image Preview
Staff Style in Score.jpg
  164KB (image/jpeg)
This image has been viewed 158 time(s).
Image Attachment :
Image Preview
Same Staff Style in linked Part.jpg
  131KB (image/jpeg)
This image has been viewed 204 time(s).
Back to Top

Dr. Wiggy
Early music: modern methods



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to Dr. WiggyAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Jun 2006
Total Posts : 12628
 
   Posted 10/23/2016 9:46 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
For the first one, are you sure that the TIFF does not have LZW compression? If you have Photoshop, resave it and make sure that is off.


Finale v.25, 2012 MacMini; 2012 MacBook Pro (10.11.6)
Edirol FA-66; Roland A-49, HP Laserjet 5200 DTN
Ancient Groove Music www.ancientgroove.co.uk

Back to Top

Michael Johnson
Registered Member



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to Michael JohnsonAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Mar 2004
Total Posts : 1317
 
   Posted 10/23/2016 10:14 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
For the second one, seems the issue is that copyable staff styles are not copied into an existing linked Part. Yes, you can "Select a region of measures and choose Use Selected Staff Style for Score and Parts to update the presence or absence of staff styles to match the selected region for the score and corresponding part(s)." for the time being.

My Steps:
New Default File
Document / Manage Parts ... / Delete the linked part
Enter some notes
Apply some Copyable Staff styles (Slash, Rhythmic Notation, Blank Notation)
Document / Manage Parts ... / Generate Parts. and then OK
Go to Linked part and see the staff styles are present
Return to score and copy your music with staff styles to other measures
Go to Linked part
Actual: Notes are copied, but staff styles are not
Expected: Notes are copied along with staff styles.


Michael Johnson

MacBook Pro
10.11
2.6 GHz Intel Core i7
8 GB RAM

Back to Top

Juraj Bartos
Registered Member

Click to send Juraj Bartos email.Click to visit Juraj Bartos's website.Send a Private Message to Juraj BartosAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Jan 1999
Total Posts : 492
 
   Posted 10/23/2016 2:55 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Dear Dr. Wiggy,

for the first one - thank you very much, indeed!
I just opened and resaved the TIFF files in Preview and voila! Finale 25 works as previous versions - shows empty rectangle with the "filename.tif" so I can easily find the file and make it embedded as I had to do with Finale 2014.5.

You are better than MM support :-)


Juraj Bartos, www.serenaders.sk

Finale 2001-2012c, Finale 2014.5, Finale 25
Tobias Giesen TGTools, Patterson Plugins, Jari Williamsson Plugins
Pro Tools 11.3.1, Waves Platinum, Sibelius 7,

MacBook Pro 15" 2,6 GHz Intel Core i7, 16 GB RAM, Mac OS X 10.10.5 (retina with SSD HD)
Korg Micro Key 61/49/25, M-Audio Keystation Mini 32

Finale 2014d, StaffPad
Microsoft Surface Pro 3 i7, 8GB RAM, 512GB SSD, Win 10

Back to Top

Juraj Bartos
Registered Member

Click to send Juraj Bartos email.Click to visit Juraj Bartos's website.Send a Private Message to Juraj BartosAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Jan 1999
Total Posts : 492
 
   Posted 10/23/2016 3:08 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Dear Michael,

thank you for your feedback, I think I am following you, but the problem is, that I always use previous Score as template without saving it into Document Styles, because Finale still does not offer more than one setting for creating Parts. I rather erase all the entries and use the created Parts from previous Score than Generate Parts again, because I use at least three different Part layouts in one Score (for example Drums, Guitar, Piano and Double Bass are formatted each in different way. The rest of the Parts use the same Format (I am waiting desperately for 64 bit JW Copy Part Layout plugin).

I think, that Staff Styles used in the Score should be automatically displayed in linked Parts by default. If there is any need to change them back to the default notation, then the Staff Style should be removed in linked Part with right mouse option like "Use deleted Staff Style in the Score".


Juraj Bartos, www.serenaders.sk

Finale 2001-2012c, Finale 2014.5, Finale 25
Tobias Giesen TGTools, Patterson Plugins, Jari Williamsson Plugins
Pro Tools 11.3.1, Waves Platinum, Sibelius 7,

MacBook Pro 15" 2,6 GHz Intel Core i7, 16 GB RAM, Mac OS X 10.10.5 (retina with SSD HD)
Korg Micro Key 61/49/25, M-Audio Keystation Mini 32

Finale 2014d, StaffPad
Microsoft Surface Pro 3 i7, 8GB RAM, 512GB SSD, Win 10

Back to Top

Zuill
"The Troll"



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to ZuillAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Oct 2003
Total Posts : 29077
 
   Posted 10/23/2016 5:52 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
The copying of staff styles bug has been around for many versions. Sorry to hear that v25 continues the bug. The workaround mentioned is the one we have been using for many versions. One would hope that the bug would eventually be fixed. Not yet, I guess.

Zuill


"When all is said and done, more is said than done."
 
Win 7 64bit, 2011b, 2012c, 2014d, 2014.5 
 
Favorite Forum quote: "Please, everybody, IGNORE THE TROLL!"

Back to Top

Michael Johnson
Registered Member



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to Michael JohnsonAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Mar 2004
Total Posts : 1317
 
   Posted 10/26/2016 5:10 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Hi Gentlemen:
Thanks for the feedback. Duly notes.
Cheers,


Michael Johnson

MacBook Pro
10.11
2.6 GHz Intel Core i7
8 GB RAM

Back to Top

Christopher Smith
Registered Member

Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to Christopher SmithAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Sep 2007
Total Posts : 2290
 
   Posted 10/27/2016 7:55 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
Michael Johnson said...
For the second one, seems the issue is that copyable staff styles are not copied into an existing linked Part. Yes, you can "Select a region of measures and choose Use Selected Staff Style for Score and Parts to update the presence or absence of staff styles to match the selected region for the score and corresponding part(s)." for the time being.

My Steps:
New Default File
Document / Manage Parts ... / Delete the linked part
Enter some notes
Apply some Copyable Staff styles (Slash, Rhythmic Notation, Blank Notation)
Document / Manage Parts ... / Generate Parts. and then OK
Go to Linked part and see the staff styles are present
Return to score and copy your music with staff styles to other measures
Go to Linked part
Actual: Notes are copied, but staff styles are not
Expected: Notes are copied along with staff styles.


I use Staff Styles a lot, especially Slash Notation. I find that it often does not show up in my parts when I apply it to the score, even when I DON'T copy it. I have reported this several times, but for some reason that last bit gets forgotten. I understand that there is a bug that doesn't copy Staff Styles correctly to parts. But there is ALSO a bug that doesn't let Staff Styles ASSIGNED FROM ZERO in the score show up correctly in the parts.

I usually wait until I have entered the entire score, then select All with the Staff Tool and select Use Selected Staff Style for Score and Parts from the Staff menu. Then, and only then, do I create multi measure rests, or add in Staff Styles that I need on the parts but not in the score, or vice-versa.


Christopher Smith

Mac Mini (Late 2014) 2.8 Ghz Intel Core i5, 8GB RAM
OSX Yosemite 10.10.5
Finale 2014.5 and V. 25
or
Macbook Pro (Retina, 13 inch, early 2015) 2.7 Ghz Intel Core i5, 8 GB RAM
OSX Yosemite 10.10.5
Finale 2014.5 and V. 25

Back to Top

Juraj Bartos
Registered Member

Click to send Juraj Bartos email.Click to visit Juraj Bartos's website.Send a Private Message to Juraj BartosAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Jan 1999
Total Posts : 492
 
   Posted 10/28/2016 11:30 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
I do the similar workaround as Christopher Smith said.
After all editing I open Piano part (Drums, Guitar etc.) and check all measures (to make the spacing better aligned I always fill measures which should contain Slash Notation and Chord Changes with quarter rests. This also shows better where Slash Notation is missing). It is true, that also measures which were not copied do not display Staff Styles defined in Score. Now imagine multiple Staff Styles (Slash, Slash with Normal notation in 3rd Layer, Rhythmic Notation, Blank Notation) which have to be applied again.
As I said, it is long lasting, annoying and time consuming bug...


Juraj Bartos, www.serenaders.sk

Finale 2001-2012c, Finale 2014.5, Finale 25
Tobias Giesen TGTools, Patterson Plugins, Jari Williamsson Plugins
Pro Tools 11.3.1, Waves Platinum, Sibelius 7,

MacBook Pro 15" 2,6 GHz Intel Core i7, 16 GB RAM, Mac OS X 10.10.5 (retina with SSD HD)
Korg Micro Key 61/49/25, M-Audio Keystation Mini 32

Finale 2014d, StaffPad
Microsoft Surface Pro 3 i7, 8GB RAM, 512GB SSD, Win 10

Back to Top
You cannot post new topics in this forum. You cannot reply to topics in this forum. Printable Version
   
Forum Information
Currently it is Saturday, December 5, 2020 7:12 AM (GMT -6)
There are a total of 403,820 posts in 58,165 threads.
In the last 3 days there were 0 new threads and 0 reply posts. View Active Threads