Finale SmartMusic
  Home | Log In | Register | Search | Help
   
MakeMusic Forum > Public Forums > Finale - Macintosh - FORUM HAS MOVED! > Finale 2014 is a nightmare. Most disappointing update in a long time  Forum Quick Jump
 
You cannot post new topics in this forum. You cannot reply to topics in this forum. Printable Version
165 posts in this thread.
Viewing Page :
 1  2  3  4  5  6  7 
[ << Previous Thread | Next Thread >> | Show Newest Post First ]

korgo
Registered Member



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to korgoAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Oct 2008
Total Posts : 9
 
   Posted 1/13/2014 7:00 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
I've only been working with Fin2014 Mac for about two weeks, now, and I have written already 15 emails to the German support about bugs. The newest addition is that the delete key on the mac keyboard (not the backspace key) is not working at all. I cannot delete the content of a bar, nor a note out of a chord, nor turn a note into a rest. All those things I frequently used the delete key for. However, if I navigate thru menus and hit the exact same function (with the delete key displayed as shortcut next to it) it works.

And that's only one of many issues.

The most obvious and frankly most annoying and questionable feature is, that EVERY operation in Fin2014 is at least half as fast as it was under Fin2011. Scrolling thru large scores is absolutely impossible and drives me nuts. There is a huge delay before audio playback starts and on and on and on... I am on a 2.8GHz Quadcore iMac with 8GB RAM and an SSD... Fin2011 still runs fast es ever. Clean installed Mavericks!

Why, why, why is a program published in 2013 running drastically slower on a recent OS, than an old program published in 2010 on the same OS? Fin2011 isn't even officially supported to run on 10.8 or 10.9!

Makes absolutely no sense at all!
Back to Top

David Ward
Registered Member



Email Address Not AvailableClick to visit David Ward's website.Send a Private Message to David WardAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Aug 2009
Total Posts : 2834
 
   Posted 1/13/2014 8:06 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
FWIW, lack of response to a key command MAY possibly be cured if you click once on the top menu bar. I found various keyboard shortcuts, including ones that are already part of the programme, were dead after my briefly going into another application and then returning to Finale. Clicking once on any Finale menu, or on the Apple menu at the extreme left, would cure this.


David Ward
www.composers-uk.com/davidward

Finale 2010b, 2014a
Mac 10.6.8, 10.8.5
full TGTools

Back to Top

Jari Williamsson
Registered Member

Click to send Jari Williamsson email.Click to visit Jari Williamsson's website.Send a Private Message to Jari WilliamssonAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Dec 1998
Total Posts : 3246
 
   Posted 1/13/2014 8:15 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
korgo said...
The most obvious and frankly most annoying and questionable feature is, that EVERY operation in Fin2014 is at least half as fast as it was under Fin2011. Scrolling thru large scores is absolutely impossible and drives me nuts. There is a huge delay before audio playback starts and on and on and on... I am on a 2.8GHz Quadcore iMac with 8GB RAM and an SSD... Fin2011 still runs fast es ever. Clean installed Mavericks!

Why, why, why is a program published in 2013 running drastically slower on a recent OS, than an old program published in 2010 on the same OS? Fin2011 isn't even officially supported to run on 10.8 or 10.9!

Makes absolutely no sense at all!


The Carbon Code in 2011 got about 10 years of optimization work, while the Cocoa code in 2014 has a couple of months since its initial release?

Anyhow, on my iMac 2014 runs faster than 2012 in terms of drawing speed, so it might be hardware/driver-dependent. Make sure to get the performance issue confirmed for your configuration (perhaps would be better to get MM's attention on the subject rather than the German support).

Smartshape pre-processing using HP is much slower during playback in 2014 than in 2012 on both Windows and Mac, but I believe that's a confirmed issue.


Jari Williamsson

Windows XP, Pentium 4
2.40 GHz, 4 GB RAM

www.finaletips.nu - The Finale Productivity Tips site

Back to Top

korgo
Registered Member



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to korgoAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Oct 2008
Total Posts : 9
 
   Posted 1/13/2014 11:15 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
I don't even use any sort of playback processing... I just play from left to right, no dynamics, nothing. Garritan J&BB library. That's it. I found soooo many bugs within just two weeks, it drives me nuts. Is there a place where all the bugs are listed in short form on this site?
Back to Top

E*L*B*
Registered Member

Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to E*L*B*AIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Feb 2004
Total Posts : 9
 
   Posted 4/29/2014 5:59 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
I am through with Finale. Seriously finished. I tried to resolve my problems with tech support - the guy had never heard of the raft of problems I was experiencing: crashing every half hour, random music being deleted and then re-pasted in random other parts of the score, inability to work with arrow keys. And the biggest, hugest problem: auto save does not work. I had it set to save every minute (because it kept crashing) I just worked on a complex piece for three hours. Crash. NOTHING WAS SAVED. Even the saves I did manually every time I remembered were not registered. I tried to reply to the message I'd gotten from Make Music about the tech support call but apparently I'm not even 'in the system' any more, even though I replied to the message I had been sent.

This has been fourteen years of working with an incredibly buggy, problematic, unwieldy and astonishingly user-unfriendly program. This is the last straw. I am switching to Sibelius, as dozens of my composer friends have urged me to do.

xxxx you, Finale. xxxx you forever.
Back to Top

Mike Rosen
himself



Email Address Not AvailableClick to visit Mike Rosen's website.Send a Private Message to Mike RosenAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Feb 2006
Total Posts : 14146
 
   Posted 4/29/2014 7:03 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
While I don't fault your complaints, why don't you just revert to an earlier version? I assume that something must have worked for you.



Mike Rosen
www.specialmillwork.com

Bass with Choir of the Sound www.choirofthesound.org
Volunteer notation editor (The Gang of Eight) for the Barbershop Harmony Society
FINALE TIPS at www.specialmillwork.com/finale-tips-and-tricks/index.html

Finale 2010, 2011, 2012c, 2014a, but using 2012 again, on Mac 10.9.2
Simple Entry, QWERTY keyboard. That's my system, and I'm stickin' to it.

"As a musician, he's a damn fine woodworker."

Back to Top

Flint
silly bear



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to FlintAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Oct 2006
Total Posts : 3151
 
   Posted 4/29/2014 7:23 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
E*L*B* said...
I am through with Finale. Seriously finished. I tried to resolve my problems with tech support - the guy had never heard of the raft of problems I was experiencing: crashing every half hour, random music being deleted and then re-pasted in random other parts of the score, inability to work with arrow keys. And the biggest, hugest problem: auto save does not work. I had it set to save every minute (because it kept crashing) I just worked on a complex piece for three hours. Crash. NOTHING WAS SAVED. Even the saves I did manually every time I remembered were not registered. I tried to reply to the message I'd gotten from Make Music about the tech support call but apparently I'm not even 'in the system' any more, even though I replied to the message I had been sent.

This has been fourteen years of working with an incredibly buggy, problematic, unwieldy and astonishingly user-unfriendly program. This is the last straw. I am switching to Sibelius, as dozens of my composer friends have urged me to do.

xxxx you, Finale. xxxx you forever.


Wait, you forgot your ball!


woodwind specialist and doubler - Finale 2014 using Speedy Entry - no capslock, GPO 4 Full, Garritan Jazz & Big Band 3, Garritan Concert and Marching Band 2, Windows 8 64-bit, 12GB RAM

If the composer says in effect to the performer: "I do not care whether you perform my music or not," we cannot argue the matter. But if he indicates: "I want you to perform and respond to this music," then his fundamental duty is to write his music so that it is accessible to interpretation. When the performer cannot approach the composer's meaning because of capriciously obscure notation, he may in effect say to the composer: "Why should I bother to puzzle out your music?" - Gardner Read

Back to Top

Dr. Wiggy
Early music: modern methods



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to Dr. WiggyAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Jun 2006
Total Posts : 12628
 
   Posted 4/30/2014 12:13 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
E*L*B* said...
the guy had never heard of the raft of problems I was experiencing: crashing every half hour, random music being deleted and then re-pasted in random other parts of the score, inability to work with arrow keys. And the biggest, hugest problem: auto save does not work. I had it set to save every minute (because it kept crashing) I just worked on a complex piece for three hours. Crash. NOTHING WAS SAVED. Even the saves I did manually every time I remembered were not registered.

There are problems with 2014, certainly. But these don't sound like them. Although Finale's auto-save has long been flaky, and I prefer not to rely on it.
However, Manual saves not working? That sounds more like catastrophic disk failure, frankly. Or PEBCAK.


(Ooh, forum fans: if you quote his text, you get to see what he really wrote instead of "xxxx"!! The lameness filter doesn't extend to quoting.)


"This is me helping."

Finale 2014a, 2012 MacMini; 2012 MacBook Pro (10.9.2)
Edirol FA-66; M-Audio Oxygen 61; Yamaha PSR-410, HP Laserjet 5200 DTN
Ancient Groove Music www.ancientgroove.co.uk

Back to Top

OCTO.
The radical answers.



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to OCTO.AIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Jul 2008
Total Posts : 2659
 
   Posted 4/30/2014 2:55 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Wiggy said...

(Ooh, forum fans: if you quote his text, you get to see what he really wrote instead of "xxxx"!! The lameness filter doesn't extend to quoting.)


I beg your pardon, I don't have 2014 and it is not a topic I should respond to, but this was THE STORY! lol
Great Wiggy!!!! :)

p.s. I believed that x means KISS. So: xxxx Finale means kiss kiss kiss kiss Finale! Forever!


Finale 2011c, OS X 10.6.8

Post Edited (OCTO.) : 4/30/2014 2:58:14 PM (GMT-5)

Back to Top

Charles Lawrence
Registered Member



Click to send Charles Lawrence email.Personal Homepage Not AvailableSend a Private Message to Charles LawrenceAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Dec 2009
Total Posts : 3638
 
   Posted 4/30/2014 5:35 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Wiggy said...
 if you quote his text, you get to see what he really wrote instead of "xxxx"!!
It must have been cleaned up, but it doesn't take much to imagine what it was.
 
The fact that this user joined the forum over 10 years ago and in the mean time has only made 8 posts tells me he must not really be much of a Finale user or shows an enormous lack of curiosity.


"Anything is possible if you don't know what you are talking about!"

 

Dell XPS 600, GenuineIntel Intel(R) Pentium(R) D CPU 3.00GHz [Intel64 Family 15 Model 4 Stepping 4] (2 processors)
8GB Ram
HT Omega Striker 7.1
MSI N430GT 2GB GPU
1TB x 4 internal HD's

Microsoft Windows 7 Ultimate x64 Edition, (06.01.7600.00)
Finale versions: 2011b.r2, 2012c.r13, 2014a.v3535

GPO4

 

"There is a world of difference between a person who has a big problem and a person who makes a problem big." – John Maxwell

Back to Top

BobRock
Registered Member

Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to BobRockAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Jan 2004
Total Posts : 433
 
   Posted 4/30/2014 6:15 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Charles Lawrence said...
Wiggy said...

if you quote his text, you get to see what he really wrote instead of "xxxx"!!
It must have been cleaned up, but it doesn't take much to imagine what it was.


The fact that this user joined the forum over 10 years ago and in the mean time has only made 8 posts tells me he must not really be much of a Finale user or shows an enormous lack of curiosity.
Or doesn't tend to overestimate the importance of this forum.
Back to Top

gracenote
Registered Member

Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to gracenoteAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Jun 2007
Total Posts : 339
 
   Posted 5/1/2014 12:18 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
I cannot even open the 2014a update on my Mac so, while he may be exaggerating, I have seen very bad performance and multiple crashes even after a fresh install of the program with all elements deleted. Reverting to 2012 in my case was a necessity although i also have the original version of 2014, which does work on my machine. Not sure why the A update, which was supposed to fix a multitude of bugs, has made the program unusable. Waiting with hope for update B.


GN

Specs: Mac Mini, OS 10.9x; 2.5ghz, 4GB ram

Finale 2012, 2014 (not a), Casio Privia 88keys

Back to Top

Vaughan
Registered Member

Click to send Vaughan email.Personal Homepage Not AvailableSend a Private Message to VaughanAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Jun 1999
Total Posts : 4984
 
   Posted 5/1/2014 4:22 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
GN, have you read the posts about why the 2014a update doesn't load on some systems? It was pretty easy for me to pinpoint; it opened fine on my MacBookPro but not on the MacPro. It turned out to be my non-Thunderbolt Apple Cinema Display which has two cables, one for video and the other for microphone/camera. This latter was mono which turned out to be the problem, as it made Finale unable to load its audio engine. Unplugging this made me able to use 2014a on the MacPro. Perhaps 2014a is having problems with one of your peripherals (sorry, I know that sounds rude).


Vaughan

Finale 3.2 - 2014, Sibelius 4 - 7
Tobias Giesen's plugins, full version, Robert Patterson plugins, Dolet 6 plugin
MacOS 10.9.2
MacPro 6GB, MacBookPro (2011) 8GB
Kontakt 4.2

Amsterdam

Back to Top

gracenote
Registered Member

Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to gracenoteAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Jun 2007
Total Posts : 339
 
   Posted 5/1/2014 2:30 PM (GMT -6)    Quote This PostAlert An Admin About This Post.
Vaughan said...
GN, have you read the posts about why the 2014a update doesn't load on some systems? It was pretty easy for me to pinpoint; it opened fine on my MacBookPro but not on the MacPro. It turned out to be my non-Thunderbolt Apple Cinema Display which has two cables, one for video and the other for microphone/camera. This latter was mono which turned out to be the problem, as it made Finale unable to load its audio engine. Unplugging this made me able to use 2014a on the MacPro. Perhaps 2014a is having problems with one of your peripherals (sorry, I know that sounds rude).


That could be. I have an external Logitec Web cam which is set as the default mic. I could change it to the basic internal mic and try it. The Logitec app has a pull down menu so I can switch back easily. Thanks for the info. Weird that 2014 (no A) works ok.


GN

Specs: Mac Mini, OS 10.9x; 2.5ghz, 4GB ram

Finale 2012, 2014 (not a), Casio Privia 88keys

Back to Top

Dr. Wiggy
Early music: modern methods



Email Address Not AvailablePersonal Homepage Not AvailableSend a Private Message to Dr. WiggyAIM Not AvailableICQ Not AvailableY! Not AvailableMSN Not Available
Date Joined Jun 2006
Total Posts : 12628
 
   Posted 5/2/2014 3:36 AM (GMT -6)    Quote This PostAlert An Admin About This Post.
FWIW, I have a Logitec Webcam (a 910 or thereabouts) and have not had any problems with Finale 2014 relating to that. I haven't installed any Logitec software, though.


"This is me helping."

Finale 2014a, 2012 MacMini; 2012 MacBook Pro (10.9.2)
Edirol FA-66; M-Audio Oxygen 61; Yamaha PSR-410, HP Laserjet 5200 DTN
Ancient Groove Music www.ancientgroove.co.uk

Back to Top
You cannot post new topics in this forum. You cannot reply to topics in this forum. Printable Version
165 posts in this thread.
Viewing Page :
 1  2  3  4  5  6  7 
   
Forum Information
Currently it is Saturday, December 5, 2020 3:52 AM (GMT -6)
There are a total of 403,820 posts in 58,165 threads.
In the last 3 days there were 0 new threads and 0 reply posts. View Active Threads