The original version of this page can be found at : http://forum.makemusic.com/default.aspx?f=12&m=261998
Posted By : arnocello - 6/19/2009 6:54 PM
I'm a longtime Finale user, just finally getting around to trying Finalescript. This script, to insert four measures each in a large set of cello exercises, opens the "Insert Measures" dialogue box, types a 4 into the number box, and then sits there. I tried several ways of expressing the "hit ok"--with and without quotations, prepending "expect", etc. and get the same result. Any advice?

Here's the script:

measure tool
select menu item "insert measure stack"
type "4"
hit ok

Thanks,
Arnold

Posted By : arnocello - 6/21/2009 12:06 PM
So many views, but no answers! I've submitted my question to Tech Support, and will post the answer they provide. :)

Posted By : Jetcopy - 6/22/2009 2:44 PM
I couldn't get your script to do anything. Maybe you left out a few steps.

But I was able to create a script that inserted 4 measures. This script will add 4 measures before the existing measure 5 of a file.

selection tool
select measure 5
menu item "insert measure stack"
type "4"
hit ok


G4 Powerbook, OSX 10.4.11, 1.67 GHz, 2 GB ram


Posted By : arnocello - 6/22/2009 7:10 PM
Thanks for the suggestion. Apparently Finale's technical support does not support Finalescript. Hmmm.

Your suggested script has the same result for me as my previous one does, the How Many Measures dialogue box appears, and then just sits there,
and I have to manually press OK or return or enter.

If it helps, I'm running Finale 2009 on an iMac with system 10.5.7.

Posted By : Bill Stevens - 6/23/2009 10:16 AM
The script Jetcopy provided worked for me. Are you using 2009 or 2009a? I don't know if that upgrade would make any difference on Finalescript.

Maybe try a different command and put "OK" in quotes, like:

press "ok"

Bill


Finale 2009b (have 2010 but not using it)
Staff Paper and #2 Pencil


Posted By : arnocello - 6/25/2009 9:08 PM
Hi Bill,
I have 2009b. One of the variations I tried was 'press "ok"', with the same strange result. Perhaps I have a missing preference or some other arcane problem. Maybe 2010 will solve it? Time will tell.

Thanks,
Arnold ("arnocello")

Posted By : Dr. Wiggy - 6/26/2009 7:51 AM
Does it work for you with any other dialog box?


Finale 2009b, 2Ghz iMac, OS X 10.5.7, M-Audio Audiophile USB
M-Audio Oxygen 61; Yamaha PSR-410
Ancient Groove Music
www.ancientgroove.co.uk


Posted By : Mircea - 9/15/2009 7:57 AM
Maybe you need to tell it at what measure to insert. I am now trying to learn scripting, so no certities here, but try somehow to tell in the script exactly what measure, or to use a highlighted measure as the place of insertion. The script is missing that. That's why the other script works.


©1999 - 2009 E tot ce va spun!


Finale 2009c, Windows 7 Ultimate RC, and some more stuff...


Posted By : Robert P. - 9/16/2009 9:04 AM
Hi Arnold,

In confirm this doesn't work (true also in Finale 2010, initial release).

I will make sure this will be addressed.

Thank you and sorry for the inconvenience,
Robert


2.4 GHz Intel Core 2 Duo MacBook Pro, 3GB RAM
Mac OS X 10.4.11 / 10.5 / [Win XP]


Posted By : Barry Lille - 10/10/2009 11:17 PM
Hi Arnold,

I'm new to FS myself. The following script worked for me in 2009C on a Mac

selection tool
select meas 2
menu item "insert measure stack"
type 4 in "how many measures"
click ok

Good Luck,

Barry