The original version of this page can be found at : http://forum.makemusic.com/default.aspx?f=12&m=278153
Posted By : UCG Musician - 12/9/2009 10:21 PM
I'm encountering a strange phenomenon with FS.  A noise sounds (like an indication that something is wrong) when certain scripts are run using a shortcut key.  The script still runs OK but the noise is rather loud & aggravating.   It's impractical to turn the computer speaker volume down each time I run the script.  The volume is at a certain level because I'm switching between speedy entry & the selection tool.  In speedy entry I hear the note I'm entering or correcting as it's set to play through MIDI.  If I run the script through the Play Button, everything's fine.
 
Similarly, the same noise sounds when I enter a command in the "Type a command" box at the bottom of the FS Palette.  In this case, however, the command will not execute.  When this happens, I have to exit Finale & re-launch it.  Nothing else works.
 
Has anyone encountered this or a similar situation?

Posted By : Dr. Wiggy - 1/2/2010 11:49 AM
Doesn't sound good. Perhaps a hardware problem. Are there any relevant messages in the system logs when the noise occurs?


Finale 2009c, 2Ghz iMac; 2Ghz MacBook, 10.6.1
Edirol FA-66; M-Audio Oxygen 61; Yamaha PSR-410
Ancient Groove Music
www.ancientgroove.co.uk


Posted By : UCG Musician - 1/3/2010 11:24 PM

Wiggy,

Thankfully it's not a hardware problem.  The issue occurs when the shortcut key I select is apparently similar to some existing shortcut.  When I enter such a shortcut key combination, I hear the same sound as I do when later running the script, although it accepts it as a viable shortcut key combo.  I have found, however, that scripts invoked through those shortcuts work intermittently.  As an example, I used a shortcut key combo of "Alt + 8" for a script to transpose three staves up an octave.  Apparently this is similar to something already in Finale because half the time it would transpose the staves DOWN an octave.  When I chose a different shortcut key, the same script worked correctly & consistently.

I also determined that when FS will not execute something typed into the "Type a command" box at the bottom of the FS Palette & makes that aggravating sound, I can get around the problem by checking the box that displays the last script action & click OK.  Then it works fine.

It took quite some time to recognize under what conditions these odd things occur but I have gotten past them now.  I just wish the little frustrations were not so frequent & inexplicable.  When everything works the way it should FS is extremely powerful & useful.  It takes too much time to resolve the idiosyncrasies.

Randy