The original version of this page can be found at : http://forum.makemusic.com/default.aspx?f=12&m=323227
Posted By : gogreen - 3/28/2011 12:24 PM
How do I get the Finalescript palette to close automatically after running a script? Is there a final script command that should be added to do that?

I am remarkably Finalescript syntax-challenged.

Thanks. freaked


Arthur J. Michaels
Finale 2000, 2001, 2003, 2005, 2006, 2007, 2011b.r2 (using 2011b.r2), Garritan CoMB
Core i7 860 @ 2.80 GHz, 8.0 GB RAM, Windows 7 Home Premium x64 SP 1
Dell 2408 WFP, 1920x1200
M-Audio Delta Audiophile 2496, M-Audio Keystation 88es
www.myspace.com/arthurjmichaels


Posted By : Mircea - 3/28/2011 6:30 PM
You have in Finale script options a "Don't show Palette when calling a script from the menu"

Playing with a menu shortcut, keyboard shortcut and this option might get you what you need. Haven't tried yet.


©1999 - 2011 E tot ce va spun!

Finale 2011
Windows 7 Ultimate 64Bit, Phenom II x4 965, 4GB RAM


Posted By : gogreen - 3/28/2011 8:37 PM
Yup. That worked. Thanks! cool


Arthur J. Michaels
Finale 2000, 2001, 2003, 2005, 2006, 2007, 2011b.r2 (using 2011b.r2), Garritan CoMB
Core i7 860 @ 2.80 GHz, 8.0 GB RAM, Windows 7 Home Premium x64 SP 1
Dell 2408 WFP, 1920x1200
M-Audio Delta Audiophile 2496, M-Audio Keystation 88es
www.myspace.com/arthurjmichaels


Posted By : Robert P. - 3/31/2011 2:33 PM
Hi Arthur,

You shall also trigger this programmatically by using the command
dont show palette
or:
hide palette

In other words, you may leave the option unchecked in the general Finalescript prefs and hide the palette for some specific script.

Robert


2.4 GHz Intel Core 2 Duo MacBook Pro, 3GB RAM
Mac OS X 10.4.11 / 10.5.8 / 10.6.3 / [Win XP]


Posted By : gogreen - 4/1/2011 9:28 PM
Cool! Thanks, Robert. I'll try that.


Arthur J. Michaels

www.arthurjmichaels.com

Finale 2000, 2001, 2003, 2005, 2006, 2007, 2011b.r2 (using 2011b.r2), Garritan CoMB
Core i7 860 @ 2.80 GHz, 8.0 GB RAM, Windows 7 Home Premium x64 SP 1
Dell 2408 WFP, 1920x1200
M-Audio Delta Audiophile 2496, M-Audio Keystation 88es


Posted By : jonnybignote - 4/9/2011 4:03 PM
sorry to jump on this thread but I have this problem and can't seem to get rid of it.

I have 'Don't show palette when calling from menu' checked

I also added both those lines you mentioned to the script itself and I still get the palette pop up after all is done (I also have 'generate detailed report' unchecked)

any ideas?


Jonathan Hughes
Macbook Pro Intel Dual Core 2.6ghz
4GB RAM Snow Leopard


Posted By : gogreen - 4/9/2011 9:31 PM
Not sure if I can help--remember, I said earlier how Finale syntax-challenged I am!

I wonder if the behavior is different on a Mac. I'm on a PC.

Do all of your scripts behave similarly, or just this one?

Try a restart.

If that doesn't work, I might try erasing the script and rewriting it from scratch.


Arthur J. Michaels

www.arthurjmichaels.com

Finale 2000, 2001, 2003, 2005, 2006, 2007, 2011b.r2 (using 2011b.r2), Garritan CoMB
Core i7 860 @ 2.80 GHz, 8.0 GB RAM, Windows 7 Home Premium x64 SP 1
Dell 2408 WFP, 1920x1200
M-Audio Delta Audiophile 2496, M-Audio Keystation 88es


Posted By : Robert P. - 4/10/2011 6:20 AM
Which version of Finale / Finalescript are you running?

R.


2.4 GHz Intel Core 2 Duo MacBook Pro, 3GB RAM
Mac OS X 10.4.11 / 10.5.8 / 10.6.3 / [Win XP]


Posted By : jonnybignote - 4/10/2011 8:29 PM
Finale 2011c r1

this affects all scripts. Have tried restarts, basic system optimizing - permissions etc.

thanks


Jonathan Hughes
Macbook Pro Intel Dual Core 2.6ghz
4GB RAM Snow Leopard


Posted By : gogreen - 4/10/2011 11:13 PM
I'm not a Mac user, but I might try a reinstallation, and then if the problem persists, I'd contact MM.


Arthur J. Michaels

www.arthurjmichaels.com

Finale 2000, 2001, 2003, 2005, 2006, 2007, 2011b.r2 (using 2011b.r2), Garritan CoMB
Core i7 860 @ 2.80 GHz, 8.0 GB RAM, Windows 7 Home Premium x64 SP 1
Dell 2408 WFP, 1920x1200
M-Audio Delta Audiophile 2496, M-Audio Keystation 88es


Posted By : Robert P. - 4/11/2011 9:39 AM
Specifically, which version of Finalescript? (Finalescript/Preferences/about)

This special version might help!

R.


2.4 GHz Intel Core 2 Duo MacBook Pro, 3GB RAM
Mac OS X 10.4.11 / 10.5.8 / 10.6.3 / [Win XP]


Posted By : Knut - 4/27/2011 5:16 PM
Just to confirm, Robert:

I had this particular problem as well, and the special version you posted did the trick.

Thanks!

Knut


15" MacBook Pro 2.6 Ghz. Intel Core 2 Duo, 4 GB RAM, RME Hammerfall DSP Multiface, Samsung SyncMaster 245b
OSX 10.6.4, Finale 2011c w/GPO & JABB, Patterson Plug-Ins, TG-Tools and QuickKeys 4; Sibelius 6, Logic Studio 8, Adobe CS3, FontLab Studio 5, FontExplorer X Pro