The original version of this page can be found at : http://forum.makemusic.com/default.aspx?f=12&m=487886
Posted By : OCTO. - 11/2/2016 5:06 AM
I try to make a script for changing the accidentals.
I want to use Special Tool - Accidental Mover - Select one accidental and than:
  • Enter
  • Uncheck "Use Default Accidental Font"
  • Click "Set Font…"
  • Select font: Engraver Font Extras
  • Enter
  • Uncheck "Use Default Character"
  • Type "J" near to "Select…"
  • Enter


...I cannot select the font.




Finale 2014.5 • OS X: Yosemite, MPB 15', 16GB RAM

Post Edited (OCTO.) : 11/2/2016 4:12:21 AM (GMT-5)


Posted By : OCTO. - 11/2/2016 5:29 AM
I have found:
choose item from list "Engraver Font Extras"




Finale 2014.5 • OS X: Yosemite, MPB 15', 16GB RAM

Post Edited (OCTO.) : 11/2/2016 6:37:52 AM (GMT-5)


Posted By : OCTO. - 11/21/2016 10:37 AM
Hi everyone. This script works on OS X but not on Windows. What is wrong? I can't go further, it stops at: Click "Set Font…

<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<script name="QT_B-down">
    <shortcut command="" enable="0" in-menu="1" />
    <lines>
        <line content="Enter" />
        <line content='Uncheck "Use Default Accidental Font"' />
        <line content='Click "Set Font…"' />
        <line content='choose item from list "Engraversuper"' />
        <line content="Enter" />
        <line content='Uncheck "Use Default Character"' />
        <line content='Type "G" near to "Select…"' />
        <line content="Enter" />
    </lines>
</script>




Finale 2014.5 • OS X: Yosemite, MPB 15', 16GB RAM


Posted By : OCTO. - 11/23/2016 2:16 AM
OCTO. said...
Hi everyone. This script works on OS X but not on Windows. What is wrong? I can't go further, it stops at: Click "Set Font…

<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<script name="QT_B-down">
    <shortcut command="" enable="0" in-menu="1" />
    <lines>
        <line content="Enter" />
        <line content='Uncheck "Use Default Accidental Font"' />
        <line content='Click "Set Font…"' />
        <line content='choose item from list "Engraversuper"' />
        <line content="Enter" />
        <line content='Uncheck "Use Default Character"' />
        <line content='Type "G" near to "Select…"' />
        <line content="Enter" />
    </lines>
</script>


I have discovered why. I swap the mouse click to use with LH, and Finale doesn't know that.




Finale 2014.5 • OS X: Yosemite, MPB 15', 16GB RAM