The original version of this page can be found at : http://forum.makemusic.com/default.aspx?f=12&m=79720
Posted By : mkelley - 4/27/2004 12:30 PM
Now that the new patch has been posted I will assume my "open ftm" problem is fixed. However, is there anyway to specify a specific template or file be opened? If not, could this be considered for the next release?

I'm using template files to get around some of the limitations in FinaleScript (like changing MIDI setups) but being able to specify the file without having the Open dialog would be a lot more useful and powerful.

Posted By : mkelley - 4/27/2004 12:50 PM
Ah, I guess I spoke too soon.

I downloaded the latest FinaleScript patch and put it in the right directory, but the "open ftm" still doesn't work (neither does "open template"). In either case I don't get a dialog box at all anymore (in the older version the dialog came up for all document choices).

I've tried:

open ftm
open 'ftm'
open template

none of which work for me. Now, I'd much rather open a "specific" template, but it would also be nice to get this working.

Posted By : Michael Johnson - 4/27/2004 4:35 PM
Hi mkelley --
I will document your request to be able to specify the name of the file to open. However, I can not reproduce the problem you describe of not opening ftm files.
Here are my steps.
Create a new script
//Script start
batch process folder
open Marching Band.ftm
//Script end
Set batch process folder to Finale 2k4b/templates/band templates
run script.
All templates in the folder are opened. It would be great to see only the Marching band template.
Sincerely,


Michael Johnson
QA Supervisor
MakeMusic!


Posted By : mkelley - 4/27/2004 4:51 PM
I usually don't do this, but I'll reply twice <g>.

Your example works probably because you are batch processing -- but what if you only want to process the currently open document?

Open works without batch processing, so open ftm should work the same way. Not everything needs (or wants) to be done in batch processing mode.

Posted By : Michael Johnson - 5/5/2004 3:11 PM
Hi mkelley--
I see your point and I can confirm that open <file type> only works in the batch process mode. I hope we can address the problem.
Sincerely,


Michael Johnson
QA Supervisor
MakeMusic!