The original version of this page can be found at : http://forum.makemusic.com/default.aspx?f=6&m=482779
Posted By : Jocko_23 - 8/17/2016 2:23 PM
Hi,

just installed the demo version and found something that does not work as it did in 2014.5 and before:

Preface: In countries where the metric system is used, we write "1,25cm" and not "1.25cm".

In the new Finale, when I go to page layout - edit system (or page) margins, the "," is not accepted any longer. Finale translates "1,25" to "1", obviously ignoring the two digits behind the ",". When I type "1.25cm" it works.
No idea about the US keyboard layout, but in my (German) layout the "," is beneath the "0" in the number block, whrer it logically should be to make typing quick and easy.

Hope this can be fixed easily (maybe automatically linked to the choice of cm in the preferences?) - or is there any preference option that I did not find???

Greetings Jock


Finale 2011b - Win7 64bit home
Finale 2014d - Mac OS X


Posted By : Michel R. E. - 8/17/2016 2:26 PM
I live in a country that uses metric, and in English we use the dot for fractions: "1.25cm".
However, in Québec, where the spoken language is French, they use a comma: "1,25cm".

Personally, I see no logic to using a comma, I never have. In math, fractions of a unit have always been separated from the unit with a dot.


Finale (started with ver. 3.0) using 2012 and now 2014 under Windows 8.1
basically ALL Garritan libraries, plus XSample Chamber Ensemble.

"Art critics suffer from Pigeon Syndrome. Pigeons like to leave their mark on monuments. But at the end of the day, the pigeon remains a pigeon, and the monument remains a monument."


Posted By : Jocko_23 - 8/17/2016 2:31 PM
Michel,

the logic is: Whatever system you use, the dot or comma should be beneath the 0.
And, for a big part of the world, you are simply wrong - fractions of a unit are separated by a comma! (Guess why I wrote 1comma25cm...)


Finale 2011b - Win7 64bit home
Finale 2014d - Mac OS X


Posted By : Michel R. E. - 8/17/2016 2:48 PM
On none of my keyboards is either the dot or comma immediately beneath the zero. So there's that. However, BOTH the comma and dot are more or less below the 0 but on the bottom line of keys of the keyboard (easy thumb access for both).

By the way, I'm not "simply wrong". I stated two examples, in the country where I live. I followed that up with my opinion, which is neither right nor wrong. It is simply my view on the issue. It's an opinion that comes from 50 years of seeing it that way. I was brought up with dots as separators (before the French started using commas).

Anyway, if this is an important enough issue for you, the best suggestion would be to contact MakeMusic directly, rather than post on the forum.
Making feature requests or bug reports on this forum is almost pointless. It's really just a user forum with minimal participation from any MM staff.


Finale (started with ver. 3.0) using 2012 and now 2014 under Windows 8.1
basically ALL Garritan libraries, plus XSample Chamber Ensemble.

"Art critics suffer from Pigeon Syndrome. Pigeons like to leave their mark on monuments. But at the end of the day, the pigeon remains a pigeon, and the monument remains a monument."

Post Edited (Michel R. E.) : 8/17/2016 1:51:24 PM (GMT-5)


Posted By : David Ward - 8/17/2016 2:51 PM
New Zealand (I used to be married to a New Zealand woman) is 100% metric, but uses the dot rather than a comma for the decimal point.

Here in Scotland (as in the rest of the UK) we are substantially but not completely metric (and God knows where we'll be going after Brexit - if that will even apply to Scotland: an unholy shambles the whole thing), and we use the stop but not the comma for decimal fractions.

I think it has more to do with the language used than whether or not one is using metric units.


David Ward
www.composers-uk.com/davidward

Finale 2014d & 2014.5 with Mac 10.9.5 & 10.11.6
Finale 2010b with Mac 10.6.8
full TGTools

Since 2001 have used F 2001, 2003, 2007, 2009, 2010, 2014

“We enjoy the comfort of opinion without the discomfort of thought.” JFK

Post Edited (David Ward) : 8/17/2016 2:03:25 PM (GMT-5)


Posted By : Motet - 8/17/2016 6:25 PM
Michel R. E. said...
I was brought up with dots as separators (before the French started using commas).

I believe the French have always used commas. French Canadians, maybe not.

/en.wikipedia.org/wiki/Decimal_mark


Finale 2014.5, 2011b, 2005, TGTools
Windows 7, MIDI input
Finale Transposition Chart

Post Edited (Motet) : 8/17/2016 5:31:58 PM (GMT-5)


Posted By : michelp - 8/17/2016 6:53 PM
Motet said...
I believe the French have always used commas. French Canadians, maybe not./en.wikipedia.org/wiki/Decimal_mark

Correct. Europeans who speak French use the comma.


Michel
Finale 2014.5, 2014d, 2012c (main), 2011c, 2010b, 2009b, MacOsX 10.9.5, Mac Mini Intel Core i7 2,7 Ghz, 16 Go Ram, French azerty kb, Dolet 6. Full TGTools. MOTU Audio Express, 3 monitors.


Posted By : Jeff Hamburg - 8/18/2016 6:46 AM
And some Europeans who don't speak French also use the comma.


Jeff Hamburg

iMac 3.5 GHz i7 OS 10.11, Finale 2.0.1 --->2014d, 8 gb ram, 30" HP ZR30w, EWQLSO Silver Play, XSample Chamber Ensemble, Numark USB Audio Interface UA-1ex, M-Audio Keystation88


Posted By : Jocko_23 - 8/19/2016 7:42 AM
Okay, so now I have learned that the comma-dot issue is language-related and has nothing to do with metric vs. imperial.

Still, there is a problem with the comma on the numeric block, see also "dotted notes in Finale 25" here in the Mac subforum. Michel, your idea is good, I will try to contact MM and see if they have a fix or workaround.

If not: I am on a Mac for a bit more than a year only, so there is a lot to learn for me...
Is there a way (script or app or whatever) that remaps the dot to the comma (on the numeric block only!) every time I open Finale 25 and does vice versa when I close it?
Does this (linking to Finale only) work with TypeIt4Me?
Any help greatly appreciated.

BTW: Michel, what kind of keyboards do you use? On every keyboard with a numeric block (and that's what it is all about) that I know there is either a comma or a dot on the right hand side of the 0.

Jock


Finale 2011b - Win7 64bit home
Finale 2014d - Mac OS X

Post Edited (Jocko_23) : 8/19/2016 6:50:08 AM (GMT-5)


Posted By : Vaughan - 8/21/2016 4:47 AM
Most of us who use Finale can't do without some kind of macro program. You can accomplish a lot with MacOS system shortcuts, but a dedicated macro program which can not only simulate menu selections and other user actions like mouse clicks, but record an entire series of actions, is indispensable. I've used QuicKeys for years and it's been very trustworthy but, as it hasn't been updated for many years, I've been using it on borrowed time and I'm eventually going to have to switch to Keyboard Maestro. With a program like one of these, you can map the dot on the numeric pad to produce a dot instead of a comma only when invoked within Finale. This would seem to be the best way to go. If there are other, similar problems, you could even create a macro to change the keyboard layout when starting up Finale and to change it back when quitting.


Vaughan

Finale 3.2 - 25, Sibelius 4 - 7
Robert Patterson plugins, waiting for Tobias' and Jari's plugin update
MacOS 10.11.6
MacPro (2016) 16 GB, MacBookPro (2011) 8 GB

Amsterdam


Posted By : CCMP - 8/21/2016 5:43 AM
Why is this problem only in Finale 25? In Fin 2014.5 the dot on the numeric keyboard works fine for note-length.


CCMP (Cees Coenen Music Productions)

WWW.CCMP.NL

Finale 2014.5 - Logic Pro X - Ableton Live on OS X 10.10.5 (Yosemite)
Session Horns Pro - Garritan JABB - Garritan Concert and Marching Band - EZ Drummer - Superior Drummer - Spectrasonics Omnisphere and Trillian


Posted By : Domi - 8/21/2016 5:57 AM
CCMP, same problem and question overhere! Very strange, Make Music shouldn't have changed this, or it's a bug?, AND they should offer a solution to solve this problem! (instead of having to install/buy/use other Third-party programs such as Quickeys, Keyboard Maestro, ...)

Posted By : Wim Lasoen - 8/26/2016 9:24 AM
It's completely ridiculous how thousands of users with AZERTY keyboards are left in the cold here. Come on MM fix this and fast please!

Posted By : Wim Lasoen - 10/1/2016 10:57 AM
No reaction from the finale board...

Don't tell me you are simply ignoring this bug until another big update will be released...

Any workaround WITHOUT simple edit or keyboard config program, fellow users?


Finale 25
GPO 5 and IRCAM SOLO INSTRUMENTS
Logic Pro X


Posted By : Mike Rosen - 10/1/2016 11:21 AM
Possibly they've included a fix in the next release. But we won't know until it happens. It's very rare that they announce what has been selected for repair.



Mike Rosen
www.specialmillwork.com

Bass with Choir of the Sound www.choirofthesound.org
Volunteer copyist (The Gang of Twelve) for the Barbershop Harmony Society
FINALE TIPS at www.specialmillwork.com/finale-tips-and-tricks/index.html

Finale 2014.5 on El Capitan
Simple Entry, QWERTY keyboard, numberpad. That's my system, and I'm stickin' to it.

"As a musician, he's a damn fine woodworker."


Posted By : N. Grossingink - 10/1/2016 11:24 AM
Did you contact Make Music? They say that an update will be released fairly soon to correct various problems in the new version. I'd say this qualifies as a "problem".

N.


OSX Mavericks 10.9.5
Finale 2011c, 2012c for production work

OSX El Capitan 10.11.6
Finale 2014.5

TgTools, Patterson Plugins, JW Change and Staff Polyphony, QuicKeys 4
Mac Mini 2.4 Ghz Intel, 8GB RAM
New Belgium Fat Tire Ale


Posted By : Wim Lasoen - 10/1/2016 11:48 AM
For the benefit of all people with keyboard troubles on the Mac: I used the free UKELELE for setting up a variant of my Belgian Keyboard with the dot programmed on the comma key (numeric pad) and it works!
Updated and also works on Sierra
http://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&id=ukelele


Finale 25
GPO 5 and IRCAM SOLO INSTRUMENTS
Logic Pro X